l10n CVS Account request for amedcj@hotmail.com for Kurdish (ku)

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: amedcj, Assigned: oremj)

Tracking

Details

(Whiteboard: ssh-key,voucher,form)

Attachments

(2 attachments)

601 bytes, text/plain
Details
736 bytes, application/octet-stream
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ku; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ku; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)

Ceng ( cengkarakus@hotmail.com ) want to breakaway from Localization Firefox for Kurdish language (ku). So localization of kurdish need a new key.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Which way is better for get a new key? Sending CVS Contributor Form by fax or by post office?
Summary: A New Key for Localization Firefox for Kurdish (ku) → l10n CVS Account request for amedcj@hotmail.com for Kurdish (ku)

Comment 2

12 years ago
Firstly, we need Erdal to vouch for you.

For the contributor form, it should be both. The fax is merely to speed up the process.

The ssh public key should be attached to this bug.
You can send the form via email if you like.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 4

12 years ago
I confirm the situation and support Amed's request for CVS access. 
(Reporter)

Comment 5

12 years ago
Hi,
i sent CVS Contributor Form to marcia@mozilla.org

Comment 6

12 years ago
Can someone please confirm this? Has Amed's mail arrived? Is there something else we need to do?
I have received the email form. You still need to attach an SSH key. Then Axel will have to approve the actual creation of the account.
(Reporter)

Comment 8

12 years ago
Created attachment 267143 [details]
SSH key

Hi,
I created id_dsa.pub for ssh key and i attached as it says here ( http://www.mozilla.org/cvs-ssh-faq.html )

Updated

12 years ago
Attachment #267143 - Attachment mime type: application/octet-stream → text/plain

Comment 9

12 years ago
Good to go, then.
Whiteboard: ssh-key,voucher,form
over to server ops for account creation.
Assignee: marcia → server-ops
Status: ASSIGNED → NEW
(Assignee)

Updated

12 years ago
Assignee: server-ops → oremj
(Assignee)

Comment 11

12 years ago
Your CVS account has been created.  Your CVSROOT should be:

   amedcj%hotmail.com@cvs.mozilla.org:/l10n

Don't forget to set your CVS_RSH environment variable to 'ssh'.

If you have any problems connecting, let me know.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

12 years ago
hi.
i think there is some thing wrong with CVS -or with me- 

~/CVS$ cvs checkout -P l10n/ku
Permission denied (publickey,gssapi-with-mic).
cvs [checkout aborted]: end of file from server (consult above messages if any)


is it because of i didnt set my CVS_RSH environment variable to 'ssh'?
how can i do it?
(In reply to comment #12)
> ~/CVS$ cvs checkout -P l10n/ku
> Permission denied (publickey,gssapi-with-mic).
> cvs [checkout aborted]: end of file from server (consult above messages if any)

What CVSROOT are you using to checkout?
 
> is it because of i didnt set my CVS_RSH environment variable to 'ssh'?
> how can i do it?

If you use bash, you need to do: export CVS_RSH="ssh"
I recommend you add that to your ~/.bash_profile or ~/.bashrc file so that it is automatically done for all of your shell sessions.
(Reporter)

Comment 14

12 years ago
i am using to chekout mozilla firefox CVSROOT

i added it to ~/.bashrc

i had created id_dsa and id_dsa.put in a komputer with ubuntu-gnome but i am using kde now. can it be because of that?

*i use bash and i did export CVS_RSH="ssh"
(In reply to comment #14)
> i am using to chekout mozilla firefox CVSROOT

No, I need the full CVSROOT you are using to checkout. It should be:
amedcj%hotmail.com@cvs.mozilla.org:/l10n

What are you using for your CVSROOT?
(Reporter)

Comment 16

12 years ago
thinks i do:
i created a folder with name /.ssh
than i put id_dsa and id_dsa.pup files into /.ssh

than i wrote
     gedit .bashrc
in terminal than i put 
     export CVSROOT=amedcj%hotmail.com@cvs.mozilla.org:/l10n
     export CVS_RSH=ssh

in file .bashrc. i created CVS folder
     mkdir CVS
i opened CVS folder
     cd CVS
in terminal first i wrote
     export CVSROOT=amedcj%hotmail.com@cvs.mozilla.org:/l10n
than
     export CVS_RSH=ssh
but when i write
     cvs checkout -P l10n/ku

it says:
~/CVS$ cvs checkout -P l10n/ku
Permission denied (publickey,gssapi-with-mic).
cvs [checkout aborted]: end of file from server (consult above messages if any)

thanx for helping

that is all i am doing
What is the output of this command:
ssh -v amedcj%hotmail.com@cvs.mozilla.org
(Reporter)

Comment 18

12 years ago
OpenSSH_4.3p2 Debian-8ubuntu1, OpenSSL 0.9.8c 05 Sep 2006
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to cvs.mozilla.org [63.245.208.155] port 22.
debug1: Connection established.
debug1: identity file /home/semra/.ssh/identity type -1
debug1: identity file /home/semra/.ssh/id_rsa type -1
debug1: identity file /home/semra/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.9p1
debug1: match: OpenSSH_3.9p1 pat OpenSSH_3.*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3p2 Debian-8ubuntu1
debug1: Miscellaneous failure
No credentials cache found

debug1: Miscellaneous failure
No credentials cache found

debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'cvs.mozilla.org' is known and matches the RSA host key.
debug1: Found key in /home/semra/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Next authentication method: gssapi-with-mic
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Next authentication method: publickey
debug1: Trying private key: /home/semra/.ssh/identity
debug1: Trying private key: /home/semra/.ssh/id_rsa
debug1: Trying private key: /home/semra/.ssh/id_dsa
debug1: No more authentication methods to try.
Permission denied (publickey,gssapi-with-mic).
Doesn't look like your SSH key is present in your ~/.ssh/ directory. What files do you have in ~/.ssh/ ?
(Reporter)

Comment 20

12 years ago
i have just id_dsa and id_dsa.pub
not more

Comment 21

12 years ago
IIRC, id_dsa had special requirements on file permissions. What's the perms on id_dsa? Or a ls -l?

Comment 22

12 years ago
IIRC, if the permissions are too permissive, there's a special warning about that.  My guess is that the sshd agent is not running.
(Reporter)

Comment 23

12 years ago
Perms are

-rwxrwxr-x 1 semra root 736 2007-06-07 20:03 id_dsa
-rwxrwxr-x 1 semra root 601 2007-06-07 20:03 id_dsa.pub

but i have changed them and tryed to chekout. but nothing happened.
what are right perms?
(In reply to comment #23)
> what are right perms?

600
(Reporter)

Comment 25

12 years ago
it is 600 now

-rw------- 1 semra root 736 2007-06-07 20:03 id_dsa
-rw------- 1 semra root 601 2007-06-07 20:03 id_dsa.pub

echo $CVSROOT
amedcj%hotmail.com@cvs.mozilla.org:/l10n

echo $CVS_RSH
ssh


i was using ceng's key for translation Firefox and it was id_rsa. not id_dsa
possibly can that problem be because of that?
(In reply to comment #25)
> i was using ceng's key for translation Firefox and it was id_rsa. not id_dsa
> possibly can that problem be because of that?

No, id_dsa is fine, as you attached a public key of a dsa key.

Make sure ~/.ssh is 700 (-rw-------).
(Reporter)

Comment 27

12 years ago
it is 700 (-rw-------)
:(
What's the output of this again after you fixed the perms:
ssh -v amedcj%hotmail.com@cvs.mozilla.org
(Reporter)

Comment 29

12 years ago
OpenSSH_4.3p2 Debian-8ubuntu1, OpenSSL 0.9.8c 05 Sep 2006
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to cvs.mozilla.org [63.245.208.155] port 22.
debug1: Connection established.
debug1: identity file /home/semra/.ssh/identity type -1
debug1: identity file /home/semra/.ssh/id_rsa type -1
debug1: identity file /home/semra/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.9p1
debug1: match: OpenSSH_3.9p1 pat OpenSSH_3.*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3p2 Debian-8ubuntu1
debug1: Miscellaneous failure
No credentials cache found

debug1: Miscellaneous failure
No credentials cache found

debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'cvs.mozilla.org' is known and matches the RSA host key.
debug1: Found key in /home/semra/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Next authentication method: gssapi-with-mic
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Next authentication method: publickey
debug1: Trying private key: /home/semra/.ssh/identity
debug1: Trying private key: /home/semra/.ssh/id_rsa
debug1: Trying private key: /home/semra/.ssh/id_dsa
debug1: No more authentication methods to try.
Permission denied (publickey,gssapi-with-mic).
(In reply to comment #25)
> -rw------- 1 semra root 736 2007-06-07 20:03 id_dsa
> -rw------- 1 semra root 601 2007-06-07 20:03 id_dsa.pub

Is your group actually root?

(In reply to comment #29)
> debug1: Trying private key: /home/semra/.ssh/id_dsa
> debug1: No more authentication methods to try.
> Permission denied (publickey,gssapi-with-mic).

It's not even offering the key! :/

This is so weird...
Is ssh -v actually supposed to work in this case? I mean, amed doesn't have a ssh account on that server, just cvs.

I'm getting the same error msg for ssh -v marcoos%firefox.pl@cvs.mozilla.org, even though I have no problems with cvs.
Amed, could you try the following command to initiate the checkout?

cvs -d :ext:amedcj%hotmail.com:/l10n checkout l10n/ku

(In reply to comment #31)
> Is ssh -v actually supposed to work in this case? I mean, amed doesn't have a
> ssh account on that server, just cvs.

Yes, it displays some needed verbose information in order to figure out what the issue is. All CVS users have an account on the cvs server for ssh authentication. Note that CVS_RSH is set to "ssh". This means that all connections are tunneled through ssh for authentication and security purposes. The shell for all the CVS users is a wrapper script that allows the users to  interact with the cvs repository. So, amed _does_ have an ssh account on that server, and so do you.

> I'm getting the same error msg for ssh -v marcoos%firefox.pl@cvs.mozilla.org,
> even though I have no problems with cvs.

What error message are you referring to? A full paste of your ssh -v is better.
(In reply to comment #32)
> Amed, could you try the following command to initiate the checkout?
> 
> cvs -d :ext:amedcj%hotmail.com:/l10n checkout l10n/ku

That won't work at all. Where's the repository information? How does it know to use cvs.mozilla.org? That's not even a valid CVS command at all.

CVS is not the problem here. The problem lies with amed getting his/her private key to be correctly offered during the ssh authentication process. Right now, amed's key isn't even being offered as a possible key to check against.
The one from comment 29. On the other hand, this sytax works for me:
ssh -v -l marcoos%firefox.pl cvs.mozilla.org

So maybe for Amed it should try:

ssh -v -l amedcj%hotmail.com cvs.mozilla.org

Also, I do think that the issue here is the missing ":ext:" in his cvsroot. :)
(In reply to comment #34)
> > cvs -d :ext:amedcj%hotmail.com:/l10n checkout l10n/ku
> 
> That won't work at all. Where's the repository information?

Oops, right.

cvs -d :ext:amedcj%hotmail.com@cvs.mozilla.org:/l10n checkout l10n/ku
(Reporter)

Comment 37

12 years ago
thinks i got:
for cvs -d :ext:amedcj%hotmail.com:/l10n checkout l10n/ku

Permission denied (publickey,gssapi-with-mic).
cvs [checkout aborted]: end of file from server (consult above messages if any)
semra@semra:~/CVS$ cvs -d :ext:amedcj%hotmail.com:/l10n checkout l10n/ku
ssh: amedcj%hotmail.com: Name or service not known
cvs [checkout aborted]: end of file from server (consult above messages if any)



for cvs -d :ext:amedcj%hotmail.com@cvs.mozilla.org:/l10n checkout l10n/ku

Permission denied (publickey,gssapi-with-mic).
cvs [checkout aborted]: end of file from server (consult above messages if any)
semra@semra:~/CVS$ cvs -d :ext:amedcj%hotmail.com:/l10n checkout l10n/ku
ssh: amedcj%hotmail.com: Name or service not known
cvs [checkout aborted]: end of file from server (consult above messages if any)
semra@semra:~/CVS$ cvs -d :ext:amedcj%hotmail.com@cvs.mozilla.org:/l10n checkout l10n/ku
Permission denied (publickey,gssapi-with-mic).
cvs [checkout aborted]: end of file from server (consult above messages if any)
Just to make things clear:

1) "ssh -v user@host" is the wrong syntax, the correct one is: ssh -v -l user host
2) :ext: must be included in the cvsroot (like in comment 36)

Because of (1) ssh -v was failing, and because of (2) Amed couldn't checkout anything from cvs.
(In reply to comment #38)
> Just to make things clear:
> 
> 1) "ssh -v user@host" is the wrong syntax, the correct one is: ssh -v -l user
> host
> 2) :ext: must be included in the cvsroot (like in comment 36)
> 
> Because of (1) ssh -v was failing, and because of (2) Amed couldn't checkout
> anything from cvs.

Actually, no on both counts. Both of the above statements are wrong. I just tried `ssh -v reed%reedloden.com@cvs.mozilla.org`, and it worked fine for me. Also, :ext is not needed, as it will default to external (which pulls from $CVS_RSH) if a local directory match is not possible. However, I do agree that it should be used. This, however, is not the reason for amed's problems.

Comment 40

10 years ago
Created attachment 349779 [details]
regenerate ssh key

i need a new ssh key.
i genetered one. it is in attachment.
cheers,
You need to log in before you can comment on or make changes to this bug.