Message Handling: Delete Duplicates option

RESOLVED WONTFIX

Status

Penelope
Mail Window
P5
enhancement
RESOLVED WONTFIX
12 years ago
9 years ago

People

(Reporter: David, Assigned: Matt Dudziak)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915

The Mac but not the PC version has a "delete duplicate messages" option.

Especially in a "POP but keep on server" environment; this is a lifesaver at times. {I have moved large mail folders to Mac & back to PC just for this cleanup.}

Penelope needs a duplicate detector.

Reproducible: Always
(Assignee)

Comment 1

12 years ago
Moved to NEW and assigned priority to '--'.

If you agree that Penelope needs to have a 'delete duplicates' option to prevent having 2 or more copies of the same message in your mail store, vote for this bug.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Delete Duplicates → Message Handling: Delete Duplicates option

Comment 2

12 years ago
> The Mac but not the PC version has a "delete duplicate messages" option.

Where is this in Mac Eudora?  I've never seen it before, and it would have been extremely useful dozens of times.  Show me the secret!
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)

> Where is this in Mac Eudora?  I've never seen it before, and it would have been
> extremely useful dozens of times.  Show me the secret!


Special>Setttings>Really Miscellanous.

It's not well explained; I've had to tag the whole folder, and move it to a temp one and back to get it to function.

But the first time the POP message pointer gets lost and you have dduupplliiccaattee everything, you'll love it...
 

(Assignee)

Comment 4

12 years ago
(In reply to comment #3)
> (In reply to comment #2)
> 
> > Where is this in Mac Eudora?  I've never seen it before, and it would have been
> > extremely useful dozens of times.  Show me the secret!
> 
> 
> Special>Setttings>Really Miscellanous.
> 
> It's not well explained; I've had to tag the whole folder, and move it to a
> temp one and back to get it to function.
> 
> But the first time the POP message pointer gets lost and you have
> dduupplliiccaattee everything, you'll love it...
> 
> 


By the way, to get the 'Really Miscellaneous' settings panel, you need to install the 'Esoteric Settings' plugin (Get info on the Eudora app and enable it in the plugins section of get info, then restart Eudora).

The reason it was never made a 'normal' setting/option is that it is SLOW, and that it requires a bit of trickery to get Eudora to start checking for duplicates. Trickery = moving a message into or out of the problem mailbox, if I recall correctly.

There is a third-party plugin for Win Eudora that does the same thing. I've never used it, but see http://www.softpedia.com/get/Internet/E-mail/Mail-Utilities/Delete-Duplicates-for-Eudora.shtml if you need it.

(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> 
> The reason it was never made a 'normal' setting/option is that it is SLOW....

A) It bit me back when a friend's mailer started sending Null Msg-ID's; as the mail would be invisible until I did a text dump of the INBOX and found it...

B) Maybe we want an only-manually actuated function... maybe part of the "click the index box to compress the mailbox" one?

Comment 6

12 years ago
Brilliant!  I hadn't noticed that the first and only time I turned on "Esoteric settings"... it's now enabled.  That should be a CORE setting, not an esoteric one, even if it isn't enabled by default (and given the performance of most computers now, is the speed still an issue?).  The amount of time that would have saved me already would have to be many hours at least.

Comment 7

12 years ago
> The reason it was never made a 'normal' setting/option is that it is SLOW, and
> that it requires a bit of trickery to get Eudora to start checking for
> duplicates. Trickery = moving a message into or out of the problem mailbox, if
> I recall correctly.

Well, I had to turn it on a few months ago to clear out a lot of duplicates. Didn't notice any difference in speed at all. And no trickery was required - opening the mailbox and closing it again was sufficient to clear out the duplicates.
(Reporter)

Comment 8

12 years ago

I saw a note from a local list. A member reported he had suggested (to the TBird project...) that they implement the Duplicate Detection via a sort on the message ID field. If two Message-IDs are equal, then the lengths are compared. Duplicates (or exact truncations) messages are simply thrown away.

But this being a manual vs always-on approach, it did not meet favor with the team, I gather.

If Penelope did this, I'd be happy. 

{As it happens, I have a MS Eudora6 user with a major duplicate problem that I must fix..)

Comment 9

12 years ago
I think this is already available, the base pref is mail.server.default.dup_action (see bug 9413).
(Reporter)

Comment 10

12 years ago
FYI: <https://addons.mozilla.org/firefox/956/> Remove Duplicate Messages
may be relevant...

(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED

Comment 11

11 years ago
In addition to the "remove duplicates from a mailbox" functionality, I'd like to see this as an incoming filter.  Occasionally Yahoogroups "stutters" and sends out two (or as many as FIVE) exact duplicate messages (duplicate to the byte, I've checked). There is no way short of tactical nukes to het them to fix that problem, but a bit of careful coding of the new "remove duplicates from a mailbox" function might let it run asn an inbound filter and would catch that "stuttering".  Or separate it from the "filters" tab and let it reside as a selectable feature on the inbound mail handling.

Thanks for listening.
(Assignee)

Updated

10 years ago
Priority: -- → P5
(Assignee)

Comment 12

9 years ago
There are a couple of Add-ons that do this:
https://bugzilla.mozilla.org/show_bug.cgi?id=361990
and
https://addons.mozilla.org/en-US/thunderbird/addon/4654

I'm going to close this as a result.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.