SVG <use> doesn't render when pointing to a <symbol>

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Antoine Quint, Assigned: tor)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/418.9 (KHTML, like Gecko) Safari/419.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/2006112805 Minefield/3.0a1

SVG <use> doesn't render when pointing to a <symbol>

Reproducible: Always

Steps to Reproduce:
1. create an SVG <symbol> element
2. reference it with a <use> element

Actual Results:  
Symbol reference results in no rendering

Expected Results:  
Symbol reference results in rendering of the symbol
(Reporter)

Comment 1

11 years ago
Created attachment 246842 [details]
Test case

Comment 2

11 years ago
*** Bug 362142 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

11 years ago
Used to work fine in FF 2.0
Whiteboard: Regression
Component: General → General
Keywords: regression
OS: Mac OS X 10.4 → All
Product: Firefox → Core
Hardware: Macintosh → All
Whiteboard: Regression
Version: unspecified → Trunk
Seems to be something to do with the transform matrix (viewBox) going wrong, but I don't have time to look further at this.
Status: UNCONFIRMED → NEW
Component: General → SVG
Ever confirmed: true
(Assignee)

Comment 5

11 years ago
Created attachment 246858 [details] [diff] [review]
make inner <svg> responsible for coordinate systems
Assignee: nobody → tor
Status: NEW → ASSIGNED
(Assignee)

Updated

11 years ago
Attachment #246858 - Flags: review?(jwatt)
QA Contact: general → general
Comment on attachment 246858 [details] [diff] [review]
make inner <svg> responsible for coordinate systems

thanks tor! r=jwatt
Attachment #246858 - Flags: review?(jwatt) → review+
(Assignee)

Updated

11 years ago
Attachment #246858 - Flags: superreview?(roc)
Attachment #246858 - Flags: superreview?(roc) → superreview+
(Assignee)

Comment 7

11 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.