Starting build generates missing entry point dialog

VERIFIED WORKSFORME

Status

()

Core
XPCOM
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Derwood, Assigned: use leaf@mozilla.org)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 1

18 years ago
Created attachment 7698 [details]
sample error dialog
(Reporter)

Updated

18 years ago
Component: Build Config → XPCOM

Comment 2

18 years ago
windows.
Assignee: cls → leaf

Comment 3

18 years ago
Confirmed on this morning's 41805 build. This may only be a problem on 
NT/Win2000 as at least one Win98 user I know isn't seeing this warning.

There appear to be no ill effects to Mozilla as it continues to run even after 
the warning is acknowledged.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
mass re-assign of all bugs where i was listed as the qa contact
QA Contact: cyeh → chofmann
(Reporter)

Comment 5

18 years ago
deleting user profile seems to clear the error dialog from appearing.  It also 
fixes some window setting prefs symptoms....ah the day's of Nav 2.0 
shifting prefs...
(Reporter)

Comment 6

18 years ago
Nix that, error dialog still appears afer reboot.

Comment 7

18 years ago
I think this is happening because of a pre-existing mozregistry.dat (in the
windows system directory, wherever that happens to be for you), or component.reg
in the same directory as the mozilla.exe.

Can you remove those two files and startup again?
Status: NEW → ASSIGNED
(Reporter)

Comment 8

18 years ago
Bingo.  Previously, I deleted the user profile to no effect, but the 
mozregistry.dat was it.
(Reporter)

Comment 9

18 years ago
*sigh*, nix that.  It happened again.  With the 2000050808 win32 build.

Comment 10

18 years ago
Excellent, i'm going to mark as wontfix... this is a condition that the
installer *should* be taking care of at install time.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 11

18 years ago
oops, sorry, missed your last comment... so, explain the pathology here:

You remove the file and your currently installed build works with no dialog, but
the dialog reappears when you install a new build? Or when you run a second
time?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 12

18 years ago
OK, I just nuked the profile and the mozregistry.dat and mozver.dat files and I 
still got the entry dialog when I ran the 2000050808 win32 build.

Comment 13

18 years ago
Are you using a zip file, or the installer? If the installer, are you installing
only a few components?
Status: REOPENED → ASSIGNED
(Reporter)

Comment 14

18 years ago
.zip file (the windowz d/l link from the homepage).

Comment 15

17 years ago
lohphat - still seeing this in the latest mozilla builds?  I suspect this can be
resolved worksforme.
QA Contact: chofmann → granrose
(Reporter)

Comment 16

17 years ago
Yes. WORKSFORME too
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 17

17 years ago
thanks.  marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.