copy image to other app and crash on exit [@ MSVCR80.dll] [@ nsDataObj::GetFileContentsInternetShortcut]

VERIFIED FIXED

Status

()

Core
Widget: Win32
--
critical
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: Peter6, Assigned: Ere Maijala (slow))

Tracking

({crash, regression})

Trunk
x86
Windows 2000
crash, regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

1008 bytes, patch
Stuart Parmenter
: review+
Stuart Parmenter
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061126 Minefield/3.0a1 ID:2006112613 [cairo]

repro:

1. open a page with an image
2. rightclick on the image and select copy
3. paste the image into any app
4. close Firefox

result:
Incident ID: 26629636
Stack Signature	MSVCR80.dll + 0x14e38 (0x600a4e38) f57c0aa6
Product ID	FirefoxTrunk
Build ID	2006112604
Trigger Time	2006-11-28 16:11:38.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	MSVCR80.dll + (00014e38)
URL visited	
User Comments	crash after closing browser when an image is copied from FF into another app (eg MS Paint)
Since Last Crash	9401 sec
Total Uptime	9401 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
MSVCR80.dll + 0x14e38 (0x600a4e38)
nsDataObj::GetFileContentsInternetShortcut  [mozilla\widget\src\windows\nsdataobj.cpp, line 1017]
nsDataObj::QueryInterface  [mozilla\widget\src\windows\nsdataobj.cpp, line 335]
ole32.dll + 0x3ce5b (0x7ce5ce5b)
ole32.dll + 0x3cbb8 (0x7ce5cbb8)
ole32.dll + 0x1c986 (0x7ce3c986)
USER32.DLL + 0x3158f (0x77e4158f)
USER32.DLL + 0x2c19d (0x77e3c19d)
USER32.DLL + 0x2c1ca (0x77e3c1ca)
ntdll.dll + 0x11baf (0x77f91baf)
ole32.dll + 0x3cc88 (0x7ce5cc88)

I tried this in a 2 month old build, same crash.
Will look for regressionwindow tomorrow night

Comment 1

12 years ago
This could be the same as bug 228278.  The stack that I got is closer to that bug than the one given above.  And I get the same stack when debugging.  

Incident ID: 26628240
Stack Signature	MSVCR80.dll + 0x14e38 (0x600a4e38) 62d23e2b
Product ID	FirefoxTrunk
Build ID	2006112804
Trigger Time	2006-11-28 15:29:31.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	MSVCR80.dll + (00014e38)
URL visited	copy image then close browser
User Comments	
Since Last Crash	28272 sec
Total Uptime	28272 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
MSVCR80.dll + 0x14e38 (0x600a4e38)
nsDataObj::GetText  [mozilla\widget\src\windows\nsdataobj.cpp, line 1160]
nsDataObj::GetData  [mozilla\widget\src\windows\nsdataobj.cpp, line 422]
ole32.dll + 0x9aa4d (0x7757aa4d)
ole32.dll + 0x9a795 (0x7757a795)
ole32.dll + 0x78e75 (0x77558e75)
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0xb4c0 (0x77d4b4c0)
USER32.dll + 0xb50c (0x77d4b50c)
ntdll.dll + 0xeae3 (0x7c90eae3)
ole32.dll + 0x9a878 (0x7757a878)
nsClipboard::Observe  [mozilla\widget\src\windows\nsclipboard.cpp, line 866]
nsObserverService::NotifyObservers  [mozilla\xpcom\ds\nsobserverservice.cpp, line 184]
NS_ShutdownXPCOM_P  [mozilla\xpcom\build\nsxpcominit.cpp, line 718]
ScopedXPCOMStartup::~ScopedXPCOMStartup  [mozilla\toolkit\xre\nsapprunner.cpp, line 598]
0x00fc4024
0xccccc3c0
(Reporter)

Comment 2

12 years ago
not bug 228278

regressionwindow (very rough)

no crash in 20060404
crashes in 20060601

I'll get the day tomorrow

Comment 3

12 years ago
Watch out though Copy Image was broken for a while:
Bug 329564

Updated

12 years ago
Assignee: nobody → win32
Severity: normal → critical
Component: General → Widget: Win32
Keywords: crash
Product: Firefox → Core
QA Contact: general → ian
Summary: copy image to other app and crash on exit [@ MSVCR80.dll] → copy image to other app and crash on exit [@ MSVCR80.dll] [@ nsDataObj::GetFileContentsInternetShortcut]
(Reporter)

Comment 4

12 years ago
regressionwindow:

works in firefox-3.0a1.en-US.win32_20060521_1352 pdt build
fails in firefox-3.0a1.en-US.win32_20060521_2213 pdt build

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-05-21+12%3A30%3A00&maxdate=2006-05-21+22%3A13%3A00&cvsroot=%2Fcvsroot

(note: paste does not work in either, but that was another bug)

Severity: critical → normal
Component: Widget: Win32 → General
Keywords: regression
Product: Core → Firefox
QA Contact: ian → general
Summary: copy image to other app and crash on exit [@ MSVCR80.dll] [@ nsDataObj::GetFileContentsInternetShortcut] → copy image to other app and crash on exit [@ MSVCR80.dll]
(Reporter)

Comment 5

12 years ago
crash in 20060521 build

Incident ID: 26631296
Stack Signature	MSVCR80.dll + 0x14e38 (0x60234e38) 3f6916e3
Product ID	FirefoxTrunk
Build ID	2006052104
Trigger Time	2006-11-28 17:04:49.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	MSVCR80.dll + (00014e38)
URL visited	
User Comments	c&p crash
Since Last Crash	64 sec
Total Uptime	31036 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
MSVCR80.dll + 0x14e38 (0x60234e38)
firefox.exe + 0x135b87 (0x00535b87)
firefox.exe + 0x134117 (0x00534117)
ole32.dll + 0x3ce5b (0x7ce5ce5b)
ole32.dll + 0x3cbb8 (0x7ce5cbb8)
ole32.dll + 0x1c986 (0x7ce3c986)
USER32.DLL + 0x3158f (0x77e4158f)
USER32.DLL + 0x2c19d (0x77e3c19d)
USER32.DLL + 0x2c1ca (0x77e3c1ca)
ntdll.dll + 0x11baf (0x77f91baf)
ole32.dll + 0x3cc88 (0x7ce5cc88)

Updated

12 years ago
Severity: normal → critical
Component: General → Widget: Win32
Product: Firefox → Core
QA Contact: general → ian
Summary: copy image to other app and crash on exit [@ MSVCR80.dll] → copy image to other app and crash on exit [@ MSVCR80.dll] [@ nsDataObj::GetFileContentsInternetShortcut]

Updated

12 years ago
Flags: blocking1.9?
(Assignee)

Updated

12 years ago
Assignee: win32 → emaijala
(Assignee)

Comment 6

12 years ago
Created attachment 246945 [details] [diff] [review]
Patch v1

Patch v1. Don't try to return text if such flavor is not available.
Attachment #246945 - Flags: superreview?(roc)
Attachment #246945 - Flags: review?(roc)
Flags: blocking1.9? → blocking1.9+

Comment 7

12 years ago
Comment on attachment 246945 [details] [diff] [review]
Patch v1

looks ok to me
Attachment #246945 - Flags: superreview?(roc)
Attachment #246945 - Flags: superreview+
Attachment #246945 - Flags: review?(roc)
Attachment #246945 - Flags: review+
(Assignee)

Comment 8

12 years ago
Fix checked in to trunk.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061203 Minefield/3.0a1 ID:2006120302 [cairo]

VERIFIED/FIXED

thanks Ere
Status: RESOLVED → VERIFIED
Crash Signature: [@ MSVCR80.dll] [@ nsDataObj::GetFileContentsInternetShortcut]
You need to log in before you can comment on or make changes to this bug.