crash at startup in Tb (en-US version) with $LC_TIME set to 'fr_BE'

RESOLVED DUPLICATE of bug 362225

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 362225
12 years ago
12 years ago

People

(Reporter: tonymec, Assigned: Scott MacGregor)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: not in yesterday's nightly)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061129 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1pre) Gecko/20061129 Thunderbird/2.0b1pre - Build ID: 2006112903

TB26648412E
TB26648768Q

These crashes are not at the same place in the code but both happened at startup a few minutes after each other.

Crash doesn't happen when starting from kde window manager's Alt-F2 prompt with $LC_TIME unset. I haven't tried to discriminate between bash script vs. kwm, or $LC_TIME set vs. unset.

Regression: Crash didn't happen in yesterday's nightly.

Reproducible: Always

Steps to Reproduce:
In bash:

export LC_TIME=fr_BE
thunderbird
Actual Results:  
crash at startup.

Expected Results:  
no crash

Additional info: 2 talkback reports


Incident ID: 26648412
Stack Signature	libc.so.6 + 0x62f28 (0x40b3ef28) 9edb5ace
Product ID	Thunderbird2
Build ID	2006112903
Trigger Time	2006-11-29 04:50:50.0
Platform	LinuxIntel
Operating System	Linux 2.6.11.4-21.14-default
Module	libc.so.6 + (00062f28)
URL visited	
User Comments	reloading Thunderbird after crash
Since Last Crash	0 sec
Total Uptime	1 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libc.so.6 + 0x62f28 (0x40b3ef28)
libc.so.6 + 0x645b4 (0x40b405b4)
libX11.so.6 + 0x1e809 (0x406a4809)
libgdk-x11-2.0.so.0 + 0x4394a (0x4051e94a)
libgdk-x11-2.0.so.0 + 0x4443e (0x4051f43e)
libgdk-x11-2.0.so.0 + 0x148b9 (0x404ef8b9)
libgdk-x11-2.0.so.0 + 0x1ec65 (0x404f9c65)
libgdk-x11-2.0.so.0 + 0x148b9 (0x404ef8b9)
libgdk-x11-2.0.so.0 + 0x1497f (0x404ef97f)
libgdk-x11-2.0.so.0 + 0x1472a (0x404ef72a)
libgdk-x11-2.0.so.0 + 0x1959b (0x404f459b)
nsDrawingSurfaceGTK::Lock()  [mozilla/gfx/src/gtk/nsDrawingSurfaceGTK.cpp, line 167]
nsBlender::Blend()  [mozilla/gfx/src/nsBlender.cpp, line 182]
nsBlender::Blend()  [mozilla/gfx/src/nsBlender.cpp, line 236]
nsViewManager::RenderViews()  [mozilla/view/src/nsViewManager.cpp, line 848]
nsViewManager::Refresh()  [mozilla/view/src/nsViewManager.cpp, line 930]
nsViewManager::DispatchEvent()  [mozilla/view/src/nsViewManager.cpp, line 1973]
HandleEvent()  [mozilla/view/src/nsView.cpp, line 251]
nsCommonWidget::DispatchEvent()  [mozilla/widget/src/gtk2/nsCommonWidget.cpp, line 219]
nsWindow::OnExposeEvent()  [mozilla/widget/src/gtk2/nsWindow.cpp, line 1435]
expose_event_cb()  [mozilla/widget/src/gtk2/nsWindow.cpp, line 3745]
libgtk-x11-2.0.so.0 + 0x11b81e (0x4032e81e)
libgobject-2.0.so.0 + 0x78db (0x405d58db)
libgobject-2.0.so.0 + 0x16d8b (0x405e4d8b)
libgobject-2.0.so.0 + 0x17ff2 (0x405e5ff2)
libgobject-2.0.so.0 + 0x18626 (0x405e6626)
libgtk-x11-2.0.so.0 + 0x202f14 (0x40415f14)
libgtk-x11-2.0.so.0 + 0x1166ee (0x403296ee)
libgdk-x11-2.0.so.0 + 0x2936d (0x4050436d)
libgdk-x11-2.0.so.0 + 0x294df (0x405044df)
libgdk-x11-2.0.so.0 + 0x29563 (0x40504563)
libglib-2.0.so.0 + 0x22051 (0x40628051)
libglib-2.0.so.0 + 0x23967 (0x40629967)
libglib-2.0.so.0 + 0x25ce2 (0x4062bce2)
libglib-2.0.so.0 + 0x26cf7 (0x4062ccf7)
libgtk-x11-2.0.so.0 + 0x116be3 (0x40329be3)
nsAppShell::Run()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
XRE_main()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 848]
main()  [mozilla/mail/app/nsMailApp.cpp, line 63]
libc.so.6 + 0x14e80 (0x40af0e80)


Incident ID: 26648768
Stack Signature	nsXULElement::InternalGetExistingAttrNameFromQName() 90d7f5a2
Product ID	Thunderbird2
Build ID	2006112903
Trigger Time	2006-11-29 05:02:28.0
Platform	LinuxIntel
Operating System	Linux 2.6.11.4-21.14-default
Module	thunderbird-bin + (00483ff0)
URL visited	
User Comments	starting up
Since Last Crash	0 sec
Total Uptime	1 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	/builds/tinderbox/Tb-Mozilla1.8/Linux_2.4.18-14_Depend/mozilla/content/xul/content/src/nsXULElement.cpp, line 115
Stack Trace 	
nsXULElement::InternalGetExistingAttrNameFromQName()  [mozilla/content/xul/content/src/nsXULElement.cpp, line 115]
nsGenericElement::GetAttribute()  [mozilla/content/base/src/nsGenericElement.cpp, line 1463]
nsXULWindow::SavePersistentAttributes()  [mozilla/xpfe/appshell/src/nsXULWindow.cpp, line 62]
nsWebShellWindow::FirePersistenceTimer()  [mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 582]
nsTimerImpl::Fire()  [mozilla/xpcom/threads/nsTimerImpl.cpp, line 395]
handleTimerEvent()  [mozilla/xpcom/threads/nsTimerImpl.cpp, line 462]
PL_HandleEvent()  [mozilla/xpcom/threads/plevent.c, line 688]
PL_ProcessPendingEvents()  [mozilla/xpcom/threads/plevent.c, line 623]
nsEventQueueImpl::ProcessPendingEvents()  [mozilla/xpcom/threads/nsEventQueue.cpp, line 421]
event_processor_callback()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 71]
libglib-2.0.so.0 + 0x4a69f (0x4065069f)
libglib-2.0.so.0 + 0x23967 (0x40629967)
libglib-2.0.so.0 + 0x25ce2 (0x4062bce2)
libglib-2.0.so.0 + 0x26cf7 (0x4062ccf7)
libgtk-x11-2.0.so.0 + 0x116be3 (0x40329be3)
nsAppShell::Run()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
XRE_main()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 848]
main()  [mozilla/mail/app/nsMailApp.cpp, line 63]
libc.so.6 + 0x14e80 (0x40af0e80)
Keywords: crash
Whiteboard: not in yesterday's nightly
Version: unspecified → 2.0
see also TB26648293M shortly before these two.
sorry, I think a crucial detail escaped me, causing this bug to be mis-reported.

*** This bug has been marked as a duplicate of 362225 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.