Contextual menus expanding off the screen - dual monitor

RESOLVED DUPLICATE of bug 314279

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 314279
12 years ago
9 years ago

People

(Reporter: Richard Brackin, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a1) Gecko/20061127 Camino/1.2+
Build Identifier: Thunderbird Trunk 11/28/06 on Mac PPC OS X US-English

Control+Clicking on a message to move it to another folder brings up a multi-tiered contextual menu. My mail reader (Thunderbird) is on my left screen. The contextual menus keep expanding to the left, ultimately clipping them away from view. (See Attachment)

Reproducible: Always

Steps to Reproduce:
-- prerequisites --
Make sure you have at least one level of subfolders under your inbox. 
Make sure you have the main app. window positioned at the top left of your left-most monitor (see my attachment to show my window placement).

1. Launch Thunderbird Trunk 11/28/06 
2. Control+Click a message to bring up the contextual menu
3. Mouse Click "Move To->" and keep clicking toward your subfolders

Actual Results:  
The contextual menus keep propogating to the left until they go off the screen. Also, the selection often 'sticks' prematurely and I have to re-start the process, but that is another bug, I guess. SeaMonkey trunk 11/28/06 has this same problem.

Expected Results:  
I would expect the contextual menu to be aware of the bounds of the viewing area and then fold back onto itself like it used to do. That way I could actually see the contents of the contextual menu.

OS X 10.4.8
(Reporter)

Comment 1

12 years ago
Created attachment 246928 [details]
This shows the contextual menus being cropped.

The main app window is on my left-most monitor. I have it positioned at the top left corner of the screen as evidenced by the screenshot.
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk

Updated

10 years ago
Assignee: mscott → nobody

Comment 2

10 years ago
Reporter, Can you confirm whether this problem is gone, or still exists on a current version of thunderbird?  

We are working to help old bugs move along, so your comment will be helpful.
Whiteboard: revisit 2008-12-18

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Summary: Contextual menus expanding off the screen → Contextual menus expanding off the screen - dual monitor
Whiteboard: revisit 2008-12-18
Duplicate of bug: 314279
You need to log in before you can comment on or make changes to this bug.