thunderbird thinks I have an unread message when I don't

RESOLVED DUPLICATE of bug 362314

Status

RESOLVED DUPLICATE of bug 362314
12 years ago
12 years ago

People

(Reporter: vdaigle, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Thunderbird 1.5.0.8

Sorry, but I can't write up a good bug report for this.  All I can do is tell you what I did before it happened.  All I did was check my mail.  The program seemed to pause an exceptionally long time on one message (which turned out to not be very big - just your basic one page text message), and then all seemed well, except that the number of unread messages was one higher than what it should have been.  So in more detail:

1.  Checked mail.
2.  Program downloaded mail but paused a long time on one message.
3.  It ran my filters (I have one that I created for a listserv I'm on, plus my junk mail filter, which I had only just today set to non-training mode) and sorted out the mail.
4.  Unread mail count in folder which contains my listserv mail was fine
5.  Unread mail count in inbox was 1 too many

I tried many things to reduce that inbox to 0 unread messages:
1.  I deleted all of the mail in the inbox (nope).
2.  I hit get mail many times (nope).
3.  I downloaded and installed Thunderbird version 3 alpha 1, which produced a C++ runtime error on installation, lol, but nope - still says I have an unread message (and yes I'm running version 3 alpha 1, apparently, despite the error, or maybe it only thinks it's version 3 alpha 1, ahem).
4.  I went to my ISP's webmail page and checked there, to see if, indeed, there was an unread message.  There was not.  There were, however, many messages there, as I have Thunderbird set to leave them on the server for a week, but I saw all of those messages get downloaded.  But to be safe, I deleted them all using my ISP's webmail interface.  Hit get mail in Thunderbird, didn't fix it.

I'm out of things to try.  Thunderbird insists that I have an unread message, but I don't.  I've read other bugs where there really was an unread message, but changing my view from read to unread threads reveals nothing, and besides, there's nothing on my ISPs server now anyway.

Something clearly went wrong, here, but I don't know what and I'm sorry but I can't help you pinpoint it because I think that reproducing it will probably be impossible (at least for me).  I didn't pay attention to see if there were any error messages when it paused on the download of that one message (I don't remember seeing anything, but I can't be 100% certain).  

Reproducible: Didn't try




If you can't figure out what went wrong, then perhaps consider incorporating a simple check and recalculation of how many messages there really are whenever it checks for new messages?  It's just an idea (and possibly not a very good one, but I wanted to toss something out there).
(Reporter)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 362314 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.