Command-line option "-profilemanager" ignored if Firefox already running

RESOLVED DUPLICATE of bug 99828

Status

()

Toolkit
Startup and Profile System
--
enhancement
RESOLVED DUPLICATE of bug 99828
11 years ago
5 years ago

People

(Reporter: Timwi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Run Firefox. Then run Firefox again with the -profilemanager option. It opens a new window in the existing instance, as if the command-line option hadn't been specified.

I suggest that it should either:
(1) offer to close the existing instance and then run the profile manager
(2) at least output a message saying that the user needs to close the existing instance before they can run the profile manager.

Reproducible: Always
Couldn't find a duplicate so confirming. 
Status: UNCONFIRMED → NEW
Component: General → Startup and Profile System
Ever confirmed: true
QA Contact: general → startup
Kinda sounds like bug 123916.
(Reporter)

Comment 3

11 years ago
The reason given in bug 123916 for marking as "invalid" is specious and nonsensical. A usability bug that is "by design" is still a usability bug that needs to be fixed.
Not really.. If an instance of firefox is already running, then starting a new instance uses the same profile as the current instance, unless you set MOZ_NO_REMOTE to indicate you want to run the new instance separate from the old one.
(Reporter)

Comment 5

11 years ago
> If an instance of firefox is already running, then starting a new
> instance uses the same profile as the current instance

There is absolutely no reason why that must necessary be the case.

I can't even see how my suggestion is hard to implement... some pseudo-code:

if (another instance exists) {
  // new code starts here
  if (command-line option "-profilemanager" is specified) {
    result = ask_user ("Would you like to close the currently-open Firefox
                        window in order to run the profile manager?");
    if (result == YES) {
      tell_the_other_instance (PLEASE_QUIT);
      open_profile_manager();
    } else {
      exit;
    }
  } else {
    // this code should already exist
    focus_the_other_instance();
    exit;
  }
}
Reasons not to do this? well, it'd be a feature that 99% of users would never use, so let's say code bloat, maintaining a codepath that is hardly ever used, requiring additional litmus tests to verify the function works when coming up for a release, another thing that could go wrong if someone else is hacking at the code, more code complexity, etc, etc.

I'm not a module owner, so who knows, perhaps someone will add this! but for me, it's a WONTFIX or INVALID, just like bug 123916.
Also, if you want to start a new instance of firefox but with a different profile, try passing it the -no-remote command.

Comment 8

11 years ago
dup of bug 362355 or bug 295693
Duplicate of this bug: 366158

Comment 10

10 years ago
This is basically the same issue as bug 99828.
(Reporter)

Comment 11

10 years ago
Clearly there are lots of duplicates of this bug, which means that lots of users are running into this problem. The argument that no-one ever uses it is clearly bogus. It's a pretty serious usability issue because the user gets confused as to why the profile manager does not appear and has no easy way of discovering how to make it appear. It is not intuitive that Firefox needs to be closed.

Please pick a bug, confirm it, and mark all the others as duplicates.

Comment 12

10 years ago
I don't think this should be fixed. WONTFIX along with all the others.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Updated

5 years ago
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 99828
You need to log in before you can comment on or make changes to this bug.