View->Toolbars->Formatting Toolbar does not have any effect.

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Matt Dudziak, Assigned: Scott MacGregor)

Tracking

({fixed1.8.1.1})

Trunk
Thunderbird2.0
fixed1.8.1.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

826 bytes, patch
Bienvenu
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
This problem is present in version 2.x and well as 3.x of Thunderbird.

The problem is that when you are a comp window and select "View->Toolbars->Formatting Toolbar" nothing happens. No toolbar appears and no toolbar disappears. The only change is the menu item gets checked/unchecked

To reproduce:
- New message
- Select View->Toolbars->Formatting Toolbar
- Note the formatting toolbar remains. No toolbar is changed/added/removed, though the menu item now does not have a check next to it.
- Select View->Toolbars->Formatting Toolbar again
- Note the formatting toolbar remains. No toolbar is changed/added/removed, though the menu item now has a check next to it again.

If the menu item is not supposed to do anything, it should not be in the menus. If it is intended to do something, it should do it. If it is not applicable, the item should be grayed out.
(Assignee)

Comment 1

11 years ago
It used to hide/show the HTML toolbar.

Looks like it's throwing a JS error:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "goToggleToolbar is not defined" {file: "chro
me://messenger/content/messengercompose/MsgComposeCommands.js" line: 501}]' when
 calling method: [nsIController::doCommand]"  nsresult: "0x80570021 (NS_ERROR_XP
C_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/conten
t/globalOverlay.js :: anonymous :: line 156"  data: yes]
************************************************************

(Assignee)

Comment 2

11 years ago
Created attachment 247111 [details] [diff] [review]
the fix

goToggleToolbar was accidentally removed as part of the work in Bug 359653. Restore the function to utilityOverlay.js.
Attachment #247111 - Flags: superreview?(bienvenu)

Comment 3

11 years ago
Comment on attachment 247111 [details] [diff] [review]
the fix

I know you're just restoring this code, but we could either get rid of the local var "attribValue" since we only use it once, or maybe we could move the
if (element)
  element.setAttribute("checked", "true"/"false" outside the if else statement and pass in attribValue for the "true"/"false" arg.
Attachment #247111 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 4

11 years ago
Created attachment 247117 [details] [diff] [review]
better fix

This version is tighter than the old implementation. Is this what you were thinking?
Attachment #247111 - Attachment is obsolete: true
Attachment #247117 - Flags: superreview?(bienvenu)

Comment 5

11 years ago
Comment on attachment 247117 [details] [diff] [review]
better fix

if that works, great - I'm not sure if you have to use "true" and "false" or if real booleans work...
Attachment #247117 - Flags: superreview?(bienvenu) → superreview+
*** Bug 362407 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

11 years ago
fixed on the branch and trunk.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.1
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird2.0
Verified fixed 1.8.1.3 with build Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620 using the steps to reproduce. View-Toolbars-Formatting Toolbar works as expected
You need to log in before you can comment on or make changes to this bug.