Printing to HP inkjet printer, last line on every printed page is cut off.

RESOLVED DUPLICATE of bug 150416

Status

()

RESOLVED DUPLICATE of bug 150416
12 years ago
11 years ago

People

(Reporter: kernel, Unassigned)

Tracking

1.8 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

If you go to the example URL, and click on the 'print article' link, and if your printer is an 'HP PSC 2175 all-in-one' printer using US Letter size paper, the last line of the page will be cut off.  This may be because the printer can't print into that area.

However, in an effort to fix this, I clicked on 'Printer properties' in the printer dialog box, and tried to set the bottom margin to something like 1 inch.  The dialog box refuses to let me!  I type in '1', it replaces it with '0.5'!  In addition, 0.5 still isn't enough to fix the problem, as the last line is still being cut off!

Reproducible: Always

Steps to Reproduce:
1. Find a website with more than 1 page of plain text
2. Print preview (shows all of the text on each page)
2. File/Print...
3. Properties
4. Try changing the bottom margin to '1'
5. Give up changing bottom margin, print to file
6. Print to printer


Actual Results:  
When you print to a file, you can view the file with kghostview or some other postscript viewer, and all the lines are there, but if you print that file to this printer, the last line is below the printer's limits, and is cut off.

When you print to the printer, the last line is below the printer's limits again, and is cut off.


Expected Results:  
I'd like to see every line on the page to be printed to this defective printer.

Also, the printer properties page should let me set a 1-inch bottom margin.  For that matter, it should let me set a 10-inch bottom margin if I'm feeling really snarky.

Yes, I realize that the 'correct' solution is to throw out this printer and buy one that can print all the way to the bottom.

One solution is to fix the bottom margin dialog box so I can ask for a 1-inch margin if I really need it.

Another solution (for me at least) is to find out how I can tell Firefox that my page isn't really a US Letter, it's about 0.5 inch shorter than that.  Do you know how Firefox reads page sizes, or is it hardcoded?  In 'Enscript' and 'A2ps' (ascii to postscript conversion programs) they have a letter size of 'Letterdj', which is 0.5 inches shorter than Letter.  Here's the comment from /etc/enscript.cfg on Fedora Core 4:

# HP DeskJet media (DeskJet can't print on the bottom 1/2" of the paper).
Media:  A4dj            595     842     24      50      571     818
Media:  Letterdj        612     792     24      40      588     768
Assignee: nobody → printing
Component: General → Printing
Product: Firefox → Core
QA Contact: general
Version: unspecified → 1.8 Branch

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 150416
You need to log in before you can comment on or make changes to this bug.