Last Comment Bug 362455 - Build system does not honor --disable-printing
: Build system does not honor --disable-printing
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 All
: -- normal with 1 vote (vote)
: Thunderbird 3.3a1
Assigned To: Jory A. Pratt
:
Mentors:
: 482312 584046 (view as bug list)
Depends on:
Blocks: 448369
  Show dependency treegraph
 
Reported: 2006-12-01 02:13 PST by Mumia W.
Modified: 2010-08-24 06:27 PDT (History)
10 users (show)
standard8: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
.3-fixed


Attachments
respects the --disable-printing flag for gtk2 (3.33 KB, patch)
2008-03-28 15:47 PDT, Brad Lassey [:blassey] (use needinfo?)
benjamin: review-
Details | Diff | Splinter Review
unified version of patch [Checkin: Comment 10] (5.24 KB, patch)
2008-04-02 07:13 PDT, Brad Lassey [:blassey] (use needinfo?)
roc: review+
roc: superreview+
Details | Diff | Splinter Review
initial start on fixing the build code (2.18 KB, patch)
2010-08-02 19:21 PDT, Jory A. Pratt
no flags Details | Diff | Splinter Review
Fully fix --disable-printing in tb (4.81 KB, patch)
2010-08-02 20:16 PDT, Jory A. Pratt
no flags Details | Diff | Splinter Review
fix missed printing in mailnews/base/build/nsMsgFactory.cpp (7.37 KB, patch)
2010-08-03 20:45 PDT, Jory A. Pratt
no flags Details | Diff | Splinter Review
intergrate all changes that Robert had made as well. (13.11 KB, patch)
2010-08-18 17:30 PDT, Jory A. Pratt
standard8: review+
kairo: feedback+
Details | Diff | Splinter Review
comm-1.9.2-disable-printing (8.65 KB, patch)
2010-08-19 16:39 PDT, Jory A. Pratt
no flags Details | Diff | Splinter Review
comm-1.9.2-disable-printing (7.37 KB, patch)
2010-08-19 16:42 PDT, Jory A. Pratt
standard8: review+
standard8: approval‑thunderbird3.1.3+
Details | Diff | Splinter Review

Description Mumia W. 2006-12-01 02:13:58 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5 Mnenhy/0.7.4.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5 Mnenhy/0.7.4.0

The Mozilla build system for building Thunderbird (trunk)
does not honor this ./configure option: --disable-printing .

The make fails with this output:
> nsMessenger.cpp:86:32: nsIWebBrowserPrint.h: No such file or directory
> In file included from nsMessenger.cpp:133:
> nsMsgPrintEngine.h:53:32: nsIWebBrowserPrint.h: No such file or directory
> nsMsgPrintEngine.h:60:30: nsIPrintProgress.h: No such file or directory
> nsMsgPrintEngine.h:61:36: nsIPrintProgressParams.h: No such file or directory
> nsMsgPrintEngine.h:62:38: nsIPrintingPromptService.h: No such file or directory

Most probably there are many other places in the code where the --disable-priting option isn't recognized also.



Reproducible: Always

Steps to Reproduce:
1. Install Thunderbird trunk from CVS.
2. Configure it with the --disable-printing option to ./configure
3. Compile Thunderbird using "make" (GNU make).

Actual Results:  
nsMessenger.cpp:86:32: nsIWebBrowserPrint.h: No such file or directory
In file included from nsMessenger.cpp:133:
nsMsgPrintEngine.h:53:32: nsIWebBrowserPrint.h: No such file or directory
nsMsgPrintEngine.h:60:30: nsIPrintProgress.h: No such file or directory
nsMsgPrintEngine.h:61:36: nsIPrintProgressParams.h: No such file or directory
nsMsgPrintEngine.h:62:38: nsIPrintingPromptService.h: No such file or directory
In file included from nsMessenger.cpp:133:
nsMsgPrintEngine.h:119: error: `nsIPrintingPromptService' was not declared in
   this scope
nsMsgPrintEngine.h:119: error: template argument 1 is invalid
nsMsgPrintEngine.h:119: error: ISO C++ forbids declaration of `
   mPrintPromptService' with no type
nsMsgPrintEngine.h:121: error: `nsIPrintProgress' was not declared in this
   scope
nsMsgPrintEngine.h:121: error: template argument 1 is invalid
nsMsgPrintEngine.h:121: error: ISO C++ forbids declaration of `mPrintProgress'
   with no type
nsMsgPrintEngine.h:122: error: `nsIPrintProgressParams' was not declared in
   this scope
nsMsgPrintEngine.h:122: error: template argument 1 is invalid
nsMsgPrintEngine.h:122: error: ISO C++ forbids declaration of `
   mPrintProgressParams' with no type


Expected Results:  
I expected Thunderbird to be built without printing support.
Comment 1 timeless 2006-12-01 02:40:50 PST
let's just drop --disable-printing
Comment 2 Benjamin Smedberg [:bsmedberg] 2006-12-01 06:29:18 PST
If you're ok with that from a small-device embedding perspective, I'm all for it!
Comment 3 Mumia W. 2006-12-01 12:31:15 PST
Supporting --disable-printing would allow people to remove a
significant amount of bulk from their builds of Thunderbird.

And naturally, in a "small-device embedded" environment, the
printing code is a gratuitous waste of space.

The --disable-printing option is a good idea.
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2008-03-28 15:47:20 PDT
Created attachment 312388 [details] [diff] [review]
respects the --disable-printing flag for gtk2

as noted in previous comments, this helps for mobile where we're missing certain headers
Comment 5 Benjamin Smedberg [:bsmedberg] 2008-04-01 11:34:24 PDT
Comment on attachment 312388 [details] [diff] [review]
respects the --disable-printing flag for gtk2

I need this to be a unified diff... it's really hard to see what has changed here.
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2008-04-02 07:13:58 PDT
Created attachment 313083 [details] [diff] [review]
unified version of patch
[Checkin: Comment 10]
Comment 7 Magnus Melin 2008-04-02 09:12:11 PDT
Brad: you need to set the review flag like before.
Comment 8 Mark Banner (:standard8) 2008-07-01 13:37:04 PDT
Brad: anything happening with this? Was the reviewed patch checked in?

IMHO this looks like it should be a core/build config bug now as its obviously not just Thunderbird that's affected.
Comment 9 Dimitrios Apostolou 2008-07-01 20:07:16 PDT
I verify that the situation is similar when building firefox 3. Even when I build with --disable printing, the gtk+-unix-print-2.0 headers and libraries are still needed and the build fails because they are not available in my system. 

Perhaps this bug should also refer to firefox, not only thunderbird?
Comment 10 Serge Gautherie (:sgautherie) 2008-07-29 02:21:59 PDT
Comment on attachment 313083 [details] [diff] [review]
unified version of patch
[Checkin: Comment 10]

http://hg.mozilla.org/mozilla-central/index.cgi/log?rev=9ec74af08980
Comment 11 Serge Gautherie (:sgautherie) 2008-07-29 02:29:52 PDT
On my Windows 2000,

Firefox 3.1a2pre builds fine.

But SeaMonkey v2.0a1pre does not:
{{
.../mailnews/base/src/nsMessenger.cpp(83) : fatal error C1083: Cannot open include file: 'nsIWebBrowserPrint.h': No such file or directory
}}

***

Brad, could you port your GTK2 patch to the other platforms ?
Comment 12 Jory A. Pratt 2010-08-02 18:46:18 PDT
This is still very much a problem in tb-3.1.1.

nsMessenger.cpp:82:32: fatal error: nsIWebBrowserPrint.h: No such file or directory
compilation terminated.
Comment 13 Jory A. Pratt 2010-08-02 19:21:49 PDT
Created attachment 462304 [details] [diff] [review]
initial start on fixing the build code

This is just a start, there is much more that will needed to be completed before we will have a working build.
Comment 14 Jory A. Pratt 2010-08-02 20:16:48 PDT
Created attachment 462312 [details] [diff] [review]
Fully fix --disable-printing in tb

This has been fully tested with both --disable-printing and --enable-printing. I have been unable to find any regressions using it.
Comment 15 Jory A. Pratt 2010-08-03 19:12:31 PDT
*** Bug 482312 has been marked as a duplicate of this bug. ***
Comment 16 Jory A. Pratt 2010-08-03 19:14:00 PDT
*** Bug 584046 has been marked as a duplicate of this bug. ***
Comment 17 Jory A. Pratt 2010-08-03 20:45:19 PDT
Created attachment 462662 [details] [diff] [review]
fix missed printing in mailnews/base/build/nsMsgFactory.cpp
Comment 18 Robert Kaiser 2010-08-05 05:40:50 PDT
I think attachment 462613 [details] [diff] [review] should be the same as this patch here, if not, it would be nice to integrate the very few differences and get all this resolved at once, as the duping suggests.
Comment 19 Robert Kaiser 2010-08-08 09:43:05 PDT
*** Bug 482312 has been marked as a duplicate of this bug. ***
Comment 20 Jory A. Pratt 2010-08-18 17:30:08 PDT
Created attachment 467248 [details] [diff] [review]
intergrate all changes that Robert had made as well.

Robert if you could double check to ensure that I did not overlook any of your changes as well would be appreciated.
Comment 21 Mark Banner (:standard8) 2010-08-19 09:14:44 PDT
Comment on attachment 467248 [details] [diff] [review]
intergrate all changes that Robert had made as well.

r=Standard8

Note: If you want this to get into 1.9.2 then we'll need a 1.9.2 version of this patch - I think the one you obsoleted would actually do most of that.
Comment 22 Mark Banner (:standard8) 2010-08-19 09:29:32 PDT
Checked in: http://hg.mozilla.org/comm-central/rev/0eb496737b06
Comment 23 Jory A. Pratt 2010-08-19 12:35:26 PDT
(In reply to comment #21)
> Comment on attachment 467248 [details] [diff] [review]
> intergrate all changes that Robert had made as well.
> 
> r=Standard8
> 
> Note: If you want this to get into 1.9.2 then we'll need a 1.9.2 version of
> this patch - I think the one you obsoleted would actually do most of that.

I actually have the comm-1.9.2 branch patch, just need to recheck the work before I post it for you, I actually did miss a few sections that needed to be ifdef'd.
Comment 24 Jory A. Pratt 2010-08-19 16:39:06 PDT
Created attachment 467597 [details] [diff] [review]
comm-1.9.2-disable-printing

Mark hope you can get this landed before next release.
Comment 25 Jory A. Pratt 2010-08-19 16:39:41 PDT
Reopening until we get it fixed on comm-1.9.2
Comment 26 Jory A. Pratt 2010-08-19 16:42:43 PDT
Created attachment 467599 [details] [diff] [review]
comm-1.9.2-disable-printing

Sorry included in patch was the revert of another bug. Which I will post to the correct bug.
Comment 27 Mark Banner (:standard8) 2010-08-20 00:44:36 PDT
(In reply to comment #25)
> Reopening until we get it fixed on comm-1.9.2

Jory: Our standard practice is to mark fixed once a bug is fixed on trunk. Branches are controlled by flags, see here for more info:

https://wiki.mozilla.org/Thunderbird/Landing_Patches_on_Thunderbird3.1
Comment 28 Mark Banner (:standard8) 2010-08-24 06:27:41 PDT
Checked into 1.9.2 branch:

http://hg.mozilla.org/releases/comm-1.9.2/rev/07af9eb570c3

Note You need to log in before you can comment on or make changes to this bug.