Last visited pages history stops working if "remember for last X days" is set to too large

VERIFIED DUPLICATE of bug 245421

Status

()

Firefox
Address Bar
VERIFIED DUPLICATE of bug 245421
11 years ago
11 years ago

People

(Reporter: Vesa-Matti Lehtomaa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061130 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061130 Minefield/3.0a1

Last visited pages history is cleared and no new pages are added to the history, if "Remember visited pages for last X days" setting is set for too many days.

Reproducible: Always

Steps to Reproduce:
1. Type an URL (e.g. www.cnn.com) to location bar and hit enter.  CNN page opens.
2. Go to Tools menu, select Options and open Privacy tab.
3. Put a large number to "Remember visited pages for last X days", e.g. fill it with 9s (9999...) and make sure the feature is enabled (checkbox is checked)
4. Close Firefox and open it again.
5. Try to open Last visited pages drop down menu from location bar

Actual Results:  
Drop down menu does not open as there are no last visited pages recorded

Expected Results:  
Drop down menu opens and www.cnn.com is displayed in it

This seems to happen also if "Remember visited pages for last X days" is set to 0 or it is left empty.  Found from Firefox 2.0, reproducable with nightly build of 2006-11-30
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Confirmed, but would 999999999 days be realistic :?
(Reporter)

Comment 2

11 years ago
Firefox should not allow user to enter longer periods that it can handle.  User might fill in 9999999 days hoping that visited pages are saved "forever".  So IMO validation (or auto conversion to maximum value) must be added to that field.

*** This bug has been marked as a duplicate of 245421 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

11 years ago
Verified as duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.