Closed Bug 362504 Opened 13 years ago Closed 12 years ago

OK button not enabled when attempting to open a document such as Word or Powerpoint

Categories

(Toolkit :: Downloads API, defect, trivial)

1.8 Branch
x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 264492

People

(Reporter: ssvaidya, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

In FireFox 2.0, when you attempt to download a document using the FireFox download manager and the file is already associated with an application such as Microsoft Office Word, the default associated application displays in the browser with the radio button selected, however, the OK button is not enabled by default.  Instead, you must click on one of the other radio buttons in order to enable the OK button.

Reproducible: Always

Steps to Reproduce:
1.  Use FireFox to browse to a web based e-mail application such as Yahoo
2.  Open an e-mail message that contains an attachment such as a Word document, zip file etc.
3.  Attempt to open the e-mail attachment through FireFox 2.0
4.  Notice that the default association for the file type is displayed and the radio button for "Open with..." is selected
5.  Examine the OK button in the Download Manager dialog.  Notice that the OK button is not enabled and therefore not clickable.

Actual Results:  
Unable to click on the OK button without clicking on other radio buttons first.

Expected Results:  
Be able to click the OK button to open the default file's associated application.
Does the OK button enable itself if you wait a few seconds?
Severity: major → trivial
Version: unspecified → 2.0 Branch
I have almost the same problem.
No, it does not enable itself after any amount of time.

The difference in my case is:
The download manager opens and the "ok" button is not enabled exactly as "ssvaidia" reported but when I click in the "Browser window" (or any other window for that matter) and then click back on the download manager window, the "ok" button enables itself.
i'm not sure if all this is only one bug, but i have a similar problem, when i use the downloadmanager, the "OK" button stays grayed out (even if i click on the radio buttons) Alt-Tabbing to another app, and Alt-Tabbing back seems to always help. Clicking on other windows or the desktop may help as well.

And no, it does not enable itself after any amount of time.

I've observed this bug on many different installations, all of them running Windows XP and FireFox 2.0
oh and this is not depending on the file extension being known - just had this with a .pdf file, and on this fresh installation no Acrobat yet.
The OK button is grayed out using Firefox 2.0.0.5 under both Linux and Windows.  Mac OS X does not seem to have the same bug.

In Windows, clicking on the dialog box will cause the OK button to become active, but only after some portion (perhaps all) of the file is downloaded.
could be Bug 361909 or Bug 264492
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 264492
Product: Firefox → Toolkit
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.