Cannot select address bar through Alt+D when FastFind is focused (only for IT Italian version)

VERIFIED FIXED

Status

--
trivial
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: legolas558, Assigned: l10n-it)

Tracking

({verified1.8.1.12})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1) Gecko/20061010 Firefox/2.0

Pressing Ctrl+F I pop up the FastFind bottom bar; the word "Highlight" is translated to "Evidenzia" and has the underline score under "d", that means that pressing Alt+D I will get word highlighting and I can no more select the address bar using Alt+D if FastFind is focused. I know it is possible to use Ctrl+L but I have been using Alt+D for ages and I think other italian users might have experienced the bug.

Reproducible: Always

Steps to Reproduce:
(Italian localization of Firefox 2.0)

1.pop up FastFind (using Ctrl+F) for example
2.Press Alt+D
Actual Results:  
Highlighting the search words

Expected Results:  
Selecting the address bar like when using Ctrl+L
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch

Updated

12 years ago
Assignee: nobody → l10n-it
Status: UNCONFIRMED → NEW
Component: Find Toolbar / FastFind → it-IT / Italian
Ever confirmed: true
Product: Firefox → Mozilla Localizations
QA Contact: fast.find → giacomo.magnini
Version: 2.0 Branch → unspecified
Duplicate of this bug: 371161
(Reporter)

Updated

12 years ago
Keywords: intl, ue, useless-UI
Keywords: intl, ue, useless-UI
The solution is to change the accesskey of "Evidenzia" from "d" to "n".

Fix is already checked in to trunk (findbar.dtd, rev 1.6), so I'm marking the bug as FIXED.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Created attachment 297392 [details] [diff] [review]
Patch for branch 1.8, changing accesskey of "evidenzia" from "d" to "n"

Hope we're still in time for 1.8.1.12 code freeze (a modified findbar.dtd has already been tested locally on Mozilla/5.0 (Windows; U; Windows NT 6.0; it;
rv:1.8.1.12pre) Gecko/20080116 BonEcho/2.0.0.12pre)
Attachment #297392 - Flags: approval1.8.1.12?
(Reporter)

Comment 4

11 years ago
Thank you very much Francesco, it took 1 year but finally the bug is fixed.

Comment 5

11 years ago
Comment on attachment 297392 [details] [diff] [review]
Patch for branch 1.8, changing accesskey of "evidenzia" from "d" to "n"

[it] approval for accesskey fix. The .12 release just got pushed out a week, so we actually have time to take this, too.

Please use the keywords again to track landing and testing.
Attachment #297392 - Flags: approval1.8.1.12? → approval1.8.1.12+
Checking in findbar.dtd;
/l10n/l10n/it/toolkit/chrome/global/findbar.dtd,v  <--  findbar.dtd
new revision: 1.2.2.11; previous revision: 1.2.2.10
Keywords: fixed1.8.1.12
Verified on trunk, build Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.9b3pre) Gecko/2008011604 Minefield/3.0b3pre
Status: RESOLVED → VERIFIED
Verified on branch 1.8, build Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.8.1.12pre) Gecko/20080117 BonEcho/2.0.0.12pre
Keywords: fixed1.8.1.12 → verified1.8.1.12
You need to log in before you can comment on or make changes to this bug.