Innacurate Error message when Profile stored on mapped Network Drive

VERIFIED DUPLICATE of bug 278860

Status

()

defect
--
minor
VERIFIED DUPLICATE of bug 278860
13 years ago
13 years ago

People

(Reporter: vmelody, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

From IT Management perspective, I have written scripts so that when
a user logs into any computer it maps their r drive and the script looks to see if their FireFox and Thunderbird settings are already configured to be saved to their r:\mozilla\Firefox or thunderbird folder.  The r: drive is mapped
to a netappliance file server.  (\\server.domain.com\username\secured)
It is important to have it on the network fileserver for 2 reasons staff use
multiple machines and have access to all their settings and 2 the server is backed up every night.

If for some reason the r drive does not map...the user gets the message -> 

Firefox is already running, but is not responding. To open a new window you must first close existing FireFox Process, or restart your system.
or 
Thunderbird is already running, but is not responding. To open a new window you must first close existing Thunderbird Process, or restart your system.

As soon as you remap the network drive both applications work fine.  So it would be useful if the both applications error check could look to see if the profile actually existed and whether or not the drive it was mapping was there also and then give the appropriate error message.

Reproducible: Always

Steps to Reproduce:
1. Create a new profile and place it on a network drive
2. Once the profile is connected - shutdown the application
3. Disconnect the mapped drive manually.
4. Launch the application.


Actual Results:  
It pops up a window stating one of the following:
Firefox is already running, but is not responding. To open a new window you must first close existing FireFox Process, or restart your system.
or
Thunderbird is already running, but is not responding. To open a new window you must first close existing Thunderbird Process, or restart your system.

Expected Results:  
I would expect the application to look for the profile.ini file which I am sure 
it does.  But I would expect it to look to see if the profile existed or that the drive letter that was referenced existed and an appropriate error message then be displayed.

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.