"Find in this page" does not follow the focus for the current frame

RESOLVED DUPLICATE of bug 253494

Status

()

defect
RESOLVED DUPLICATE of bug 253494
13 years ago
8 years ago

People

(Reporter: sam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

First of all... apologies if this bug has already been submitted but I did do a search for...
"Find in this page" +frames +focus

OK.. the bug:
Try going to http://java.sun.com/j2se/1.4.2/docs/api/ and search for "JButton"... which will be highlighted in the Class list Frame... Then click anywhere in the actual class frame and search for "ImageOvserver"... The focus is taken back to the class list frame.

BTW.. I'm not advocating frames... I just find it easier to search the Java API with Internet Explorer.. *sigh*

Reproducible: Always

Steps to Reproduce:
1.Try going to http://java.sun.com/j2se/1.4.2/docs/api/ and search for "JButton"... which will be highlighted in the Class list Frame... Then click anywhere in the actual class frame and search for "ImageOvserver"... The focus is taken back to the class list frame.
2.
3.

Actual Results:  
Try going to http://java.sun.com/j2se/1.4.2/docs/api/ and search for "JButton"... which will be highlighted in the Class list Frame... Then click anywhere in the actual class frame and search for "ImageOvserver"... The focus is taken back to the class list frame.

Expected Results:  
Try going to http://java.sun.com/j2se/1.4.2/docs/api/ and search for "JButton"... which will be highlighted in the Class list Frame... Then click anywhere in the actual class frame and search for "ImageOvserver"... The focus is taken back to the class list frame.
Component: Search → Find Toolbar / FastFind
QA Contact: search → fast.find

Comment 1

12 years ago
Here is a work around for this problem:

1.  Right click in the frame where you want to search.
2.  Select This Frame->Show Only This Frame.
3.  The browser will make that frame cover the entire window.  Then "find on this page" works.
4.  Use the back button to go back to showing all the frames.
Reporter

Comment 2

12 years ago
Another workaround is to install the IE Tab and use that (at least you don't have to leave firefox :)

https://addons.mozilla.org/en-US/firefox/addon/1419
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 253494
You need to log in before you can comment on or make changes to this bug.