Documentation incorrectly references windows menu locations and is unclear on where to set plain text format as default.

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: bkorb, Assigned: jwalden+fxhelp)

Tracking

({polish, ue})

x86
Linux
polish, ue

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Your help text says to go under the tools menu to set plain text messaging.
Makes sense.  Except "Account Settings" isn't there.  It's under "Edit".
Under "Edit" you also find "Preferences", the normal place one would
expect to be able to configure "make all messages text messages", where
I set all domains to be plain text domains.  Turns out, it is plain text only
after stripping leading white space from lines and otherwise mutilating it.
After some research, oh, yes, "Account Settings".  I had this accomplished
before, but I upgraded to the latest and lost that setting.

So, two problems:

1.  making all my messages be text belongs in "Send Options" under composition
    preferences.  If there is a compelling reason to not have this preference
    under preferences, at least add a "go see Account Settings, too" comment.

2.  I lost my all-messages-are-plain-text setting with the most recent upgrade.

Reproducible: Always

Steps to Reproduce:
1. It happens every time I upgrade to 1.5.0.8.  One out of one.
2. It is impossible to find the best place that is most obvious
   to everyone for such controls.  You can, however, cross reference
   related things and make terms like, "plain text" more easily
   searchable.
Actual Results:  
Indented text has indenting spaces stripped and reformatted
before being converted to plain text again for sending.  Why?
(Reporter)

Comment 1

12 years ago
I don't like tiny windows.  In a moment, I will send the text written
in a window where I can read what I am typing.  It will be clearer.  :)
(Reporter)

Comment 2

12 years ago
Your help text says to go under the tools menu to set plain text
messaging.  Makes sense.  Except "Account Settings" isn't there.  It's
under "Edit" instead.  Under "Edit" you also find "Preferences", the
normal place one would expect to be able to configure "make all messages
text messages".  So, before I knew to use "Account Settings", I used the
"Preferences" hierarchy to set all domains to be plain text domains.
Turns out, it is plain text only after stripping leading white space from
lines and adding line breaks long before the specified 512 character line
lengths.  After some research, ah, yes, I find I have to go to "Account
Settings" instead.  Also troublesome is the fact that I had this all
accomplished once before, but I upgraded to the latest and lost that
setting.
I think that this is a windowsism in the documentation - for windows builds Preferences and Account Settings *are* under tools, I do remember seeing this on Linux builds. 
Assignee: mscott → jwalden+fxhelp
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Message Compose Window → Help Documentation
Ever confirmed: true
Keywords: polish, ue
QA Contact: message-compose → help-documentation
Summary: Writing plain text messages is too obtuse → Documentation incorrectly references windows menu locations and is unclear on where to set plain text format as default.
Version: unspecified → 1.5
Chris, did help change in 2.x?

about>help directs to external link http://www.mozilla.org/support/thunderbird/ so I'm thinking this bug isn't valid
-->INCOMPLETE
Reporter didn't say what documentation he is referring to.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

10 years ago
It's the doc you get when you pull down the "help" menu.
Resolution: INCOMPLETE → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.