More intuitive mail handling (similar to Gmail)

RESOLVED DUPLICATE of bug 241197

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 241197
11 years ago
10 years ago

People

(Reporter: micmon, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Currently Thunderbird's interface is still very similar to what ancient versions of Netscape had. I think this should change and I think the time from 2.0 to 3.0 would be perfect for that.

As A start I propose a better way to handle mail. TB 2.0 already supports multiple mail "views" but I would really love something similar to Google Mail: grouping messages to conversations. This has many advantages over the normal threading TB uses now. But this is best described in picture:

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 247334 [details]
Mockup showing a "conversations" view in action

Perhaps left side bar sould even be totally removed and instead a rorizontal split should be done, with a mail selection above the current mail view? Then again, for widescreen monitors this is perhaps the prefered option. It's only a quick mockup and can surely be improved but I really think the way GMail handles threads/conversations should be integrated into TB or at least inspire ;)

Comment 2

11 years ago

*** This bug has been marked as a duplicate of 241197 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.