Closed Bug 362660 Opened 15 years ago Closed 15 years ago

Multiple master password dialogs competing for keyboard focus

Categories

(Toolkit :: Password Manager, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 348997

People

(Reporter: steeve.mccauley, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When starting firefox 2.0 with a restored session, and two or more of the tabs require a password the password manager dialog is opened more than once, and it is hard to get the keyboard focus to enter the password.

Reproducible: Always

Steps to Reproduce:
1. setup session restore in Prefs/Mail/Show my windows and tabs from last time
2. two or more of the tab windows should require a password that is protected by the Master Password manager
3. close and reopen firefox

Actual Results:  
Very difficult to enter the master password, multiple dialogs open requesting the master password dialgo box, and each one seems to steal the focus from the other.

Expected Results:  
One master password dialog box should open.

*** This bug has been marked as a duplicate of 348997 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.