bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

New window open should display current page not homepage

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WORKSFORME
19 years ago
7 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: jag (Peter Annema))

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

from ./ posting:

"when opening a new window, got to the current site not the home page"

seems like a good idea/option to me. adding it to my list of Things To Do.
erm, make that /. 

;)
Status: NEW → ASSIGNED
revising the description slightly, since we already support most of the 
requested behaviour via 'last page visited':

the 'open last page visited in new window' thing should be independant of the 
user's startup prefs. e.g. if I would like the browser to always start with a 
blank page, but to always spawn a new window with last page visited. 

Updated

19 years ago
Target Milestone: --- → Future

Comment 3

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 4

18 years ago
I'm gonna work on this.  So the only thing that really has to be done here is to 
ensure that opening a new navigator window from the file menu loads the current 
URL of the browser that you're spawning the new window from, right?

Comment 5

18 years ago
reassigning to myself if you don't mind, ben.
I just hacked out a simple bit which opens window.content.location.href as 
the URL when spawning a new window.  I didn't want to add a new parameter to 
OpenBrowserWindow() due to all the places it's probably used, so for now I've 
created OpenNewBrowserWindow(theurl) which does the same thing but opens theurl 
instead of startpage [am i missing an easier way to do this without creating a 
new function?  I don't suppose JS offers optional function parameters?]

So, in utilityOverlay.xul, it now reads:

<broadcaster id="cmd_newNavigator" 
oncommand="OpenNewBrowserWindow(window.content.location.href)"/>

instead of

<broadcaster id="cmd_newNavigator" oncommand="OpenBrowserWindow()"/>

as it used to.  This works simply enough, but I need to do some more testing of 
special cases (i.e. downloads.)
Assignee: ben → BlakeR1234
Status: ASSIGNED → NEW

Comment 6

18 years ago
btw, is this going to be an option (to have it load the current URL of the 
browser from which it was spawned, rather than the pref home page) or normal 
behavior (which I'd prefer, no need to clutter the prefs w/ stuff like this) ?
Status: NEW → ASSIGNED
Target Milestone: Future → M17

Comment 7

18 years ago
I would like to be able to choose what will be in the new window, I really want
all my Navigators to start with a Blank page when I say so in my prefs, not just
the first window.
However, I can see how someone wants a Home page AND new windows to open with
the current page so I guess some way to express this is needed somewhere.  Maybe
in "Navigator starts with" (Preferences/Navigator) there should be a "New
windows start with"-option with the values "Blank page", "Home page" and "Page
in old window" (or maybe "Last page visited", or both.)  Sorry if I'm
brainstorming too heavily, just giving my thoughts.  :)

Comment 8

18 years ago
blake - if you need any testing, mail me.

Comment 9

18 years ago
doron: Thanks!

ben: so, is this going to be a another pref (!) or just standard behavior?

eric: if we're going to open the same page in the new browser instance, it 
seems logical that we also open it to the same scrolling position that the user 
was at when he spawned the new window.  is this easy/feasible ?

Comment 10

18 years ago
> eric: if we're going to open the same page in the new browser instance, it 
> seems logical that we also open it to the same scrolling position that the 
> user was at when he spawned the new window.  is this easy/feasible ?

It depends on where this is being driven from / what you have access to.  If you 
can get a hold on the root frame in the frame heirarchy (nsFrame frame, not html 
frameset frame) you should be able to walk down to the scroll frame, QI to 
nsIStatefulFrame, then save it's frame state, and then restore that state on the 
new scroll frame.

If you can get access to the nsFrameManager, or session history, you could 
capture history state for the page, and restore that to the new page.  This 
would also duplicate all the values of form inputs in the new window, which 
might be a neat thing to do.  Radha is the session history guru, so she would 
know more about this option.

Comment 11

18 years ago
OK...I'll be gone for three weeks starting tomorrow.  Will look at this when I
get back.

Comment 12

18 years ago
This is more or less a dup of bug 18808.

Comment 13

18 years ago
I'd have to agree with Peter Stuge. Personally I hate it when a browser starts 
loading stuff when I open a new window (since I only open a new window when I 
want to go somewhere else, having two windows with the same page seems 
irrelevant). This is only my opinion though and I know many people like the 
behaviour, thats why I suggest that this be made pref'able, Peters idea of 
choices seems good

Updated

18 years ago
Priority: P3 → P1
Target Milestone: M17 → M20

Comment 14

18 years ago
not being familiar with older versions of Netscape I recognize this as an IE
feature. It is very good to be able to ALT+N and the browser opens with the same
page as I am currently looking at. Since it seems that some people would rather
that it opens with a blank page or their Home page, then it probably should be
an option in the Preferences. It is not the same as the "last page visited" (at
least currently (M17) it is not.

Updated

18 years ago
Blocks: 18808
As far as I can see, having this is only a problem if the browser takes a long
time to open a page.  And of course it won't before release time.  =)

Comment 16

18 years ago
It seems a "special case" error is listed in bug 56134.

Updated

18 years ago
Priority: P1 → P2
Target Milestone: M20 → mozilla1.0

Updated

18 years ago
Priority: P2 → P3

Comment 17

18 years ago
I agree with Matthew...if we don't do bug 18808, I probably wouldn't want to do 
this either, and this can really be handled over there (I'll update the summary 
to clarify).

*** This bug has been marked as a duplicate of 18808 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
No longer blocks: 18808

Comment 18

18 years ago
I recently spent a few days using msie and I found the fact that it opened
new windows to the current page EXTREMELY USEFUL. I was at an ecommerce
site on a page that would have been a pain to re-navigate to and wanted to
explore a bunch of possibilities on that page. In mozilla i could have 
right clicked on links to "open in new window" but it was a lot easier to
do it the msie way.

On the other hand I couldn't care less about copying over history from
the previous window. i'm not sure this should be a duplicate of the
other bug. Especially since the concensus seems to be against that bug.

Comment 19

18 years ago
Okay...
Status: RESOLVED → REOPENED
Depends on: 18808
Resolution: DUPLICATE → ---
blake: still planning on making this a pref or not?  This is sometimes usefull
and sometimes not. Or will you simply create a new keyboard shortcut? 1 for open
a new window with default homepage, one with current page (crtl-n and
ctrl-something-not-used)

Comment 21

18 years ago
We could use accel+1 for new window @ home page, and accel+n for new window 
based on the current window.

However I don't like that because I want accel+n to give me a blank window 
[which is my homepage].

Comment 22

18 years ago
*** Bug 55697 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
*** Bug 64005 has been marked as a duplicate of this bug. ***

Comment 24

18 years ago
I'd agree with the idea of it being a second keyboard shortcut. This would be 
better than just having it as a preference, as in one browsing session there 
might be some pages where you want to have a copy of the current page (ecommerce 
sites, search engines) and some where you don't (where you're going to a 
completely new URL and don't want the current page reprocessed).

Comment 25

18 years ago
I agree with Ben Goodger that there's something fundamentally different between
(a) starting Mozilla for the first time today, and (b) looking at one web page
and then opening a new window (from cache). I imagine that a lot of people would
like (a) to open their home page, yet (b) to open a duplicate window.

I suspect that the "When Navigator starts up, display () Blank page" option is
unnecessary. The sort of users who likes new pages to open blank can get this by
creating a (local) homepage that looks blank, then pointing Mozilla at it (with
file://) with the "display () Home page" option. (Or am I missing something ?).

Comment 26

18 years ago
the most useful of this (IE) feature IMHO is that the new window not only
displays the current page (scrolled to the same position and forms filled like
the original window), it inherits the windows' history, too.

I'm using this pretty often: If you are reading a page and want to open a page
you visited previously you just do CTRL+N and press the back-button.

This wil not work if you simply implement something like
"OpenNewBrowserWindow(window.content.location.href)".

Comment 27

18 years ago
flo@fxb.de: that's another bug.

Comment 28

18 years ago
timeless/flo@fxb.de: yes, that's bug 18808, which this is currently marked as 
depending on.

Comment 29

18 years ago
I find this behavior to be *terribly* frustrating whenever I'm using IE,
especially when I'm navigating around a site with forms on it, like for example
when buying something online. In fact, in some cases, IE even resubmits forms
when content was dynamically generated, so don't try to start a new browser
window right after your credit card gets charged.... Yeesh, what a mess.

Please, let's not have this in Mozilla.

Comment 30

18 years ago
Matt, enough people like this feature (myself included) to make
me think that an *option* should exist to allow it.
If you open a new window, you should just take a copy.  There is no call for
reloading the page.
I think you can compare the votes on this bug with bug #18808 and see what the
preferred solution is ...

Comment 33

18 years ago
I wonder what the khakis will make of this?  cc michaell, self

Comment 34

18 years ago
Er...I'd like to fix this, but we need a decision first.  -> UI Design for that.
Assignee: blakeross → mpt
Status: REOPENED → NEW
Component: Browser-General → User Interface Design
QA Contact: doronr → zach

Comment 35

18 years ago
blake: Comments From Ben Goodger 2000-04-19 03:40 seem to indicate that this 
should be dependent on a new preference. If you don't want to fix this bug, 
please reassign it to ben, form whom you stoll it.
Assignee: mpt → blakeross
Component: User Interface Design → XP Apps
QA Contact: zach → sairuh

Comment 36

18 years ago
I'm glad we have Ben's input, now I wanted the rest of the world's. -> UI Design

Comment 37

18 years ago
Really -> UI Design
Assignee: blakeross → mpt
Component: XP Apps → User Interface Design
QA Contact: sairuh → zach

Comment 38

18 years ago
At the moment, I'm thinking something like this:

| Category:             Start Pages :::::::::::::::::::::::::::::::: |
| +-------------------+                                              |
| |=Navigator=========| _New window opens:    [last-visited page :^] |
| |  Identity         | _Home page:   [http://mozilla.org/         ] |
| |  Connection       |         ( _Use Current ) ( _Choose File... ) |
| |  Helper Apps      |                                              |
| |::Start:Pages::::::| Search _button opens: [Search sidebar    :^] |
| |  History          | _Search page: [http://google.com/          ] |
| |  Temporary Files  |         ( Us_e Current ) ( Choose _File... ) |

Where the options for `New Window opens:' are:
*   last-visited page
*   home page
*   blank page.

The first Navigator window you opened in a session would always open your home 
page -- which you might set to "" or to "about:blank", if you wanted. I think 
if we had a separate UI for the first Navigator window in a session opening 
{last-visited page, home page, blank page}, alongisde the one for subsequent 
Navigator windows, users would just go `huh?'. And this is particularly 
important because the home page is a pref which the user is very likely to 
change.

I still think this bug is a first step to fixing bug 18008, rather than the 
other way around.

Comment 39

18 years ago
If we replace "when navigator starts up:" with "new window opens:", we should 
probably rename the "last page visited" option to something like "page in 
current window".  That would be more accurate, and it would also help avoid 
making NS4 users think the pref is for Navigator startup.
Thanks Blake for taking this on. You are the man!
Five things: 


A.


No matter what the prefs have, File>New Navigator Window should have a submenu 
in it that gives you the choices:
1) Blank page
2) Current page
3) Home page

The one you have currently chosen in prefs should be displayed first in the 
list and be seperated by a divider.

Therefore, the file menu would look like this:
New Navigator Window > "Your choice"
                       ____________
                       The other 2 choices
                       The other 2 choices

You should also be able to click on File>New Navigator Window itself as a 
shortcut instead of having to choose something in the submenu.


B.


Also, remember to carry over the form entries, go menu, back button, etc.


C.


This should be the default. That will make people who use IE and don't know 
prefs well happy.


D.

The "Open Link in new window" in the context menu for links should copy the 
history, go menu, forms, etc also.

E.

Perhaps instead of doing this in the prefs, it could be part of the File Menu

New Navigator Window > "Your choice"
                       ____________
                       The other 2 choices
                       The other 2 choices
                       ____________
                       New Window Default  >   Choice 1
                                             V Choice 2
                                               Choice 3
V = check


Thanks for your time.

Comment 41

17 years ago
A) Please do not add a submenu, that would be overkill.  It would be far easier
to just bring up a new window, then hit the home button or a PT bookmark, than
to select from a submenu. Also, menu items cannot have both a command and a
submenu.   
D) I don't see the need for this either, especially since IE and Nav don't do it.
E) A third level of menus? For this?  If there really is anyone who wants to
change this behavior often, perhaps there could be some combination of modifiers
to invoke the command variations directly instead?

Comment 42

17 years ago
You could instead either add a new File Menu item with submenues,
or expand today's "Open Web Location..." dialog to contain a choice
between [URL/File] (default), [Home], [Blank Page] or [Current Page].

Comment 43

17 years ago
*** Bug 87283 has been marked as a duplicate of this bug. ***

Comment 44

17 years ago
Ok, it's been two months since I posted my proposed solution. Subsequent
suggestions have been mildly amusing, but completely impractical for those 99.9
percent of people who don't know or care nearly as much about the issue as those
CCed to this bug. So, my proposal is unchanged. --> XP Apps: GUI.
Assignee: mpt → blake
Component: User Interface Design → XP Apps: GUI Features
No longer depends on: 18808
QA Contact: zach → sairuh

Updated

17 years ago
Blocks: 18808
*** Bug 87845 has been marked as a duplicate of this bug. ***

Comment 46

17 years ago
*** Bug 90283 has been marked as a duplicate of this bug. ***

Comment 47

17 years ago
Matthew, I take it this means you think the Internet Search pref panel should go...?

usability/polish, 0.9.4.
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.4
*** Bug 94451 has been marked as a duplicate of this bug. ***

Comment 49

17 years ago
This can be worked round with the following javascipt bookmark (see
http://www.bookmarklets.com/ for more). Make the following a bookmark:

javascript:dT30FfN3b=new
Date();void(window.open(location.href,'w'+dT30FfN3b.getTime()))

Does this help any?

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 50

17 years ago
<QA: You can ignore my comment>
Ok, this is a really bad idea. We want to be BETTER than all other browsers, not
compete for suckiness. If we don't get a pref for this, someone better comment
the code where this is set, so we can easily edit it out and recompile. If you
don't, I'll point my mind control ray at you, and you'r little tinfoil hats
won't protect you from my new mind control ray. It runs Linux, not Windows.
</QA>

Comment 51

17 years ago
I agree 100% with comment from Grey Hodge.

Comment 52

17 years ago
> Matthew, I take it this means you think the Internet Search pref panel should
> go...?

Yep. But that doesn't have to be done in this bug.

Comment 53

17 years ago
mpt, do the search prefs in your 2001-04-17 comment affect the search via URL
bar dropdown, at all? It's rather unclear. We need to move towards multiple
searches in the dropdown (so you can search the web, bugzilla, weather, maps),
rather then less features (this is a sepereate bug, but your spec appears to
overlap).

Comment 54

17 years ago
If anyone does this, please use MPT's suggested prefs, and honor current default
behavior. 

Comment 55

17 years ago
Mass moving lower-priority bugs to 0.9.6 (with Blake's pre-consent) to make room
for remaining 0.9.4/eMojo bugs and MachV planning, performance and feature work.
 If anyone disagrees with the new target, please let me know.
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla1.0

Comment 56

17 years ago
*** Bug 102441 has been marked as a duplicate of this bug. ***

Comment 57

17 years ago
Does this bug cover "New Tab" version of this problem? Or should be filled new bug?

Comment 58

17 years ago
See also andrews compromise in Bug 18808, which would add the current page as
the last entry in history when opening new windows, so you could click Back to
load it. This would be ideal, as you wouldn't have to reload cgi's or rerender
huge pages unless you really DID want them in the new window (which, while I
sometimes do, is a good deal less then half the time).

Comment 59

17 years ago
-->ben
Assignee: blakeross → ben
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0 → ---
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 60

17 years ago
*** Bug 125858 has been marked as a duplicate of this bug. ***

Comment 61

17 years ago
*** Bug 130582 has been marked as a duplicate of this bug. ***
Added bug 132511 on Comment #41 by Peter.

Please look at bug 108099, as this will affect the File menu and probably affect
where this can be placed in the menu.

Updated

16 years ago
Summary: [RFE] New window open should display current page not homepage → New window open should display current page not homepage

Comment 63

16 years ago
This should also apply to tabs.
Also, a possible gui implementation could be a new entry in the file menu for
"duplicate->window" or "duplicate->" (I think duplicate might be a more
intuitive term than clone),
and for tabbed viewing, possible an option for duplicate current tab in the
right click menu of the "open new tab" button. Perhaps even a new button would
be a good idea.
I think having both options is better than changing a setting in preferences. I
think it would bypass some confusion for new users, and allow experienced users
more immediate control.

Comment 64

16 years ago
typo
that "duplicate->" is supposed to be "duplicate->tab"

Comment 65

16 years ago
Another possible solution:

On the context menu (right-click anywhere on page), make it possible to
"Open current page in a new tab" in addition to the already existing 
'open current frame in a new tab'

or...

open the new tab/window with _blank, and ensure that the current page is in the
drop down history (so the user can select it from there if wanted).
*** Bug 217816 has been marked as a duplicate of this bug. ***

Comment 67

15 years ago
Eh, my Bug 217816 was marked as duplicate.

Here are my suggestions from there:
In Preferences/Navigator category, you can set to Display on new window, using
one of the following options:
* Blank page
* Home page
* Last page visited

1) I suggest to have another option in Preferences/Navigator, named:
* URL of active window (Duplicate window)

The "Last page visited" is close to the behaviour like IE has, however IE always
opens the same URL what was in the active window where you pressed the CTRL + N,
so we can say IE "duplicates the window".

2) Following key shortcuts seems to be free for Duplicate window feature:
SHIFT + ALT + D
or
ALT + D (can be used only for Windows)

3) Also into File/New/ menu, there should be a "Navigator Duplicate window
(SHIFT+ALT+D)" menu item added.

Thanks,
Webmaster33

Updated

15 years ago
Blocks: 164421
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey
Status: ASSIGNED → NEW

Comment 69

15 years ago
there are extensions out there that provides this functionality.

For example, http://www.pikey.me.uk/mozilla/#cw

<quote>
Clone Window

by Pike

Clones the current tab's address and history into a new window when the New
Window command is used (and optionally into a new tab when the New Tab command
is used).

Version:
    0.2 
Released:
    2004-01-23 
Size:
    4.73KB 
For:
    Firefox 

</quote>
*** Bug 254509 has been marked as a duplicate of this bug. ***
*** Bug 254628 has been marked as a duplicate of this bug. ***

Comment 72

14 years ago
main reason why I still prefer MS Navigator because it always start with the 
homepage that I want to see only when I press the homepage button.
Product: Core → Mozilla Application Suite
*** Bug 281917 has been marked as a duplicate of this bug. ***
Assignee: ben_seamonkey → guifeatures
QA Contact: bugzilla
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
Assignee: nobody → jag
Priority: P3 → --
QA Contact: guifeatures
Target Milestone: Future → ---

Comment 75

9 years ago
I recommend WONTFIX. Tabbed Browsing and Last Page Visited offer enough ways.

Comment 76

9 years ago
I second Hb's recommendation to WONTFIX. As previously noted, this can be accomplished with add-ons.

1. "Clone Window" by Pike:
   http://www.pikey.me.uk/mozilla/?addon=cw
2. "Duplicate Tab" by Twanno: 
   https://addons.mozilla.org/en-US/firefox/addon/28
3. "Tabberwocky" by Frank Yan:
   https://addons.mozilla.org/en-US/firefox/addon/14439

Comment 77

8 years ago
If you go to the menu bar and select [Edit > Preferences], the Preferences window comes up on the Browser pane.  There, you can set "New Window" to "Last page visited".  Thus, this RFE is not needed.  

However, there seems to be a bug in how the preferences on that window actually operate.  That should be the subject of a different bug.

Comment 78

7 years ago
Closing as WORKSFORME based on Comment 77

Comment 79

7 years ago
Oops. Actually closing.
Status: NEW → RESOLVED
Last Resolved: 18 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.