Suiterunner: Add-On Installation wont be completed after Restart

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Tobias Fischer, Assigned: jag (Peter Annema))

Tracking

Trunk
seamonkey2.0a1
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Using SeaMonkey-Suiterunner-Build 2006120311(tpol) I have tried to install Enigmail-Trunk-Nightly 2006-12-03. 
Patrick has made Enigmail compatible to Suiterunner, see http://bugzilla.mozdev.org/show_bug.cgi?id=15875

Installation starts fine, but after recommended Restart Enigmail was not installed succesfully. In Add-On-Manager it still rests with "Installation will be completed after Restart". 
I have seen this behaviour with Mnenhy and an adblock+ Build too with some older Builds. 

Going back to an really old Build (tpol 2006052400) and restart that will complete the Add-On installation. But we need the ability to install Add-Ons without Problems in Suiterunner.
I tried this recently on a linux build with tinderstatus (tinderstatus.mozdev.org) and found now problems (once it was upgraded to 0.2.3). Would you be able to try it with that?

Did you use the Restart button (on the add-on manager), or did you close SeaMonkey yourself and then start it up again?
Blocks: 328887
(Reporter)

Comment 2

12 years ago
I have tried to install Tinderstatus 0.2.3 from https://addons.mozilla.org/firefox/832/ into SeaMonkey-Suiterunner Build 2006120402 from tpol. 

After installing add-on from website, I have restarted SeaMonkey using the "Restart" Button, but opening the Add-On-manager shows "This add-on will be installed when SeaMonkey is restarted".

Closing and restart SeaMonkey won't change the installation-status for tinderstatus. Hmm.
(Reporter)

Comment 3

12 years ago
Some more testing: I have uninstalled enigmail via the Add-On-Manager, and it won't work, same failure than install an Add-On. 

When I rename the directory from ..\mozilla.org.seamonkey\suiterunner\seamonkey to ..\mozilla.org.seamonkey\suiterunner\seamonkey2006120402 and change name of older directory from ..\seamonkey2006120311 to ..\seamonkey and start 2006-12-03-11-Build, Enigmail will be uninstalled successful. 

So here I have to do the needed restart with an different Suiterunner-Build to (de-)install an add-on successful. 
Are there any messages on the error console? (Tools->Web Development->Error Console). Also if this is a zip build, can you make sure you've installed it into a clean directory?
(In reply to comment #4)
> Are there any messages on the error console? (Tools->Web Development->Error
> Console). Also if this is a zip build, can you make sure you've installed it
> into a clean directory?
> 
I should have been more explicit here:

Messages on the error console 1) after installation, before restart and 2) after restart.

Also, just as a note, my debug linux build seems to install add-ons (tinderstatus, the nightly Enigmail) fine, so this is most likely windows specific.
(Reporter)

Comment 6

12 years ago
Yes, I am using the *.zip-Builds. Because I use the XPFE-Builds too at Moment, I unzip the Suiterunner-Builds into directory:

E:\Programme\mozilla.org\suiterunner and a new subdir ..\seamonkey was created. Before unzip the new Build, I rename tho old Programmfolder from ..\seamonkey to ..\seamonkey2006121311 (seamonkeyBuildID).
So everey time there was an new folder created when I unzip the Builds. This worked fine for me with the XPFE-Builds in Directory E:\Programme\mozilla.org\

At moment Suiterunner was not my Default-Browser, default is XPFE-SeaMonkey. But this might not stop Add-On installation.

And there are no relevant Messages in Error-Console while Add-On installation. I have deinstalled Tinderstatus and reinstall from Website. 

After click Install-Button from Site, the before cleared Error-Console still stays empty. Restart SeaMonkey with "Restart"-Button will not throw clear things for me, but this three messages:

Error: varvalue has no properties
Source File: chrome://nightly/content/nightly.js
Line: 419

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.canGoBack]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://navigator/content/nsBrowserStatusHandler.js :: anonymous :: line 319"  data: no]
Source File: chrome://navigator/content/nsBrowserStatusHandler.js
Line: 319

Error: sidebarObj.panels has no properties
Source File: chrome://communicator/content/sidebar/sidebarOverlay.js
Line: 855


I will try to test this again with an new Profile, my Suiterunner-Profile was created from one of the first Builds at 2006-05-17 and might be a little broken. 


(Reporter)

Comment 7

12 years ago
After cleanup my Profile installation of add-ons will work fine and in the expected way. 
I mark this as resolved=worksforme now. 

Because there are quite less People who have an old Suiterunner-Profile like me, i hope this was not an really Problem. Sorry for the spam, next time I remember to try things with an new Profile too. And thanks for your help to point it out, Mark. 
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

12 years ago
Reopen Bug. 

After using Suiterunner some time and install, e.g. unzip new Builds to use them, cleaning up the Profile before won't help. Will do some more testing soon, to see why I have to change the current used Suiterunner-Builds to install an Add-On successful. 

Like described before, Add-Ons will install successful, when I change the Build. Example: First install mnenhy in Suiterunner-Zip-Build in directory ..\mozilla.org\seamonkey\suiterunner\suiterunner and after Restart the status was "Installation will be completed after Restart"

Then I close Suiterunner again, rename directory to e.g. ..\suiterunner2007020618 and rename older Program-Directory from ..\suiterunner2007020517 to ..\suiterunner and start the older Build, this time Mnenhy was installed successful. 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Are you installing these via the install button on the add-on manager, or just placing them in the extensions directory?

Can you also verify that there's no files missing/added between the two zip build dirs (I doubt it, but just in case).
(Reporter)

Comment 10

12 years ago
(In reply to comment #9)
> Are you installing these via the install button on the add-on manager, or just
> placing them in the extensions directory?

I am installing them via Install-Button from Add-On-Manager. I install the local saved *.xpi-Files from Disk, have not tried Online-installation yet. 

> 
> Can you also verify that there's no files missing/added between the two zip
> build dirs (I doubt it, but just in case).
> 
No difference between current used Builds from februay. There are 473 Filies in 40 Directories for the current Builds, included some plugin-files. Normally I have installed all extensions into the profil-folder.

Comment 11

12 years ago
I tried installing a dictionary from AMO on my self-built Linux build, and it worked correctly, activating it after a suiterunner restart...
(Reporter)

Comment 12

12 years ago
Manuel Reimer, PrefBar-Developer, has reported this Problem today in d.c.s.m.nb, <1170836705.86@user.newsoffice.de>, so I reopen the Bug because almost one other User see this too. 
It might be an Windows-only problem, I reproduce it at work using winXP and at home with win2k. As described in comment #7 the Add-On installation worked fine like expected via "Restart"-Button from Add-on-Manager with an clean profile, but occours again after unpack new Builds (I have renamed the old directory before, so creating a new directory ..\mozilla.org\seamonkey\suterunner\seamonkey when unzip new Build). 
Later I will try to investigate, which kind of cleaning (deleting files) in existing profile will solve the problem.
What is d.c.s.m.nb ? Sounds like a newsgroup but not one of the mozilla ones.
de.comm.software.mozilla.nightly-builds

Comment 15

11 years ago
Just to mention that this doesn't always happen but when it does the extension stays stuck in the extension/staged-xpis/ directory. Deleting this and extensions.{cache|ini|rdf} and reinstalling almost always works.

Comment 16

11 years ago
AFAIK, this works now.

Tobias, Philip, are you still seeing this?
(Reporter)

Comment 17

11 years ago
No, I don't see this anymore with new created Profiles. 

I have kicked my old experimental Suiterunner-Profiles from old tpol-Builds, and with the new created Profiles from current Trunk-Builds installation of Add-Ons works fine. 

I would like to ask Manuel Reimer (see c#12) if it works for him too, and than close this here. 
(Reporter)

Comment 18

11 years ago
I have got no response from Manuel, but because the xpi-installation works fine for me on my two machines with new Suiterunner-Profiles, I mark this as Resolved=Worksforme for now. 
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.