Icons of extensions absent in customize window

RESOLVED DUPLICATE of bug 363383

Status

()

Toolkit
Toolbars and Toolbar Customization
RESOLVED DUPLICATE of bug 363383
12 years ago
12 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:
- install an extension that adds icons in the customize window like Custom Buttons: http://forums.mozillazine.org/viewtopic.php?t=428688&postdays=0&postorder=asc&postsperpage=15&start=0&sid=9fdf618f27f44be41bcc4d0cd4fc5a17 or FirefoxMenuButtons: https://addons.mozilla.org/firefox/2046/

Result: icons are absent in customize window or when they are on the toolbar, they can't be dragged to the customize window.

Partially fixed by bug 361627 but the extension icons are not yet present.
Regression between 1.9a1_2006112209 and 1.9a1_2006112211.
There are a couple of extensions (Adblock plus for one) that currently break the customize dialog icons. Might be worth seeing if there is just one causing this.
This would appear to be an issue in the extension.  I currently see icons for Sage, FireFTP, IE View, Nightly Tester Tools, User Agent Switcher and YM Notify in my customize Toolbar window.  Therefore I think the Firefox end of this is just fine and the extensions whose Icons do not show up need to be fixed.
(Reporter)

Comment 3

12 years ago
For some reason I can't reproduce with Firefox Menu Buttons alone.
In my default profile it is a mess. After closing the customize window (where also most of my theme icons are missing, and also the User Switcher Agent icon) I can't open the customize window anymore for a second time. Because I don't get a context-menu anymore on the toolbars.
When I remove the localstore.rdf and the custom buttons extension the customize window is still empty so there must at least also be one other extension which causes these serious problems. 
(Reporter)

Comment 4

12 years ago
Yesterday I could reproduce the problem with a new profile only with Custom Buttons and FirefoxMenuButtons installed (none of the icons showed up and that caused the assumption that also e.g. FirefoxMenuButtons produced the problem) but I can't reproduce this entirely anymore. Only the Custom Button icons are still gone. 

The missing toolbar context-menu is caused by Toolbar Enhancements and has the same regression range.
(Reporter)

Comment 5

12 years ago
I'll mark this as a duplicate of Bug 363383, because of the dragging problem (in my case Custom Buttons, and in Bug 363383 Adblock Plus).
As I can't reproduce the disappearing icons (of other extensions) anymore, I'll file a new bug if the problem returns.

*** This bug has been marked as a duplicate of 363383 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.