window.opener.focus() is not working

RESOLVED DUPLICATE of bug 357814

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 357814
12 years ago
11 years ago

People

(Reporter: Allen Weng, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

it works in firefox 1.5, so I think it probably a new bug??

for example, create a file called "source.html", put the following code
<script type="text/javascript">
window.open('http://localhost/target.html');
</script>

then, create a "target.html", put the following code
<script type="text/javascript">
alert('this is target.html');

if (window.opener)
{
	window.opener.focus();
}
</script>

as http://localhost/source.html, there should be a new window with alter popup, after clicking the OK button, it stays in the popup window (target.html), it should be back to the "source.html" window


Reproducible: Always

Steps to Reproduce:
1. http://localhost/source.html 
2. on the popup dialog, click 'OK'
3. the window is not setting the focus on the "source.html" window

Actual Results:  
the foucs is on the "target.html" window

Expected Results:  
the window should set the focus on the "source.html" window
Isn't this basically bug 357814?

Updated

11 years ago
Whiteboard: DUPEME
Version: unspecified → 2.0 Branch

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 357814
You need to log in before you can comment on or make changes to this bug.