Closed Bug 362856 Opened 13 years ago Closed 13 years ago

Edit Task command from tasklist context menu does nothing

Categories

(Calendar :: Tasks, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: koen.hendrickx, Unassigned)

References

()

Details

(Whiteboard: [good first bug])

Attachments

(1 file)

Using Sunbird nightly 2006-12-05 (linux)

In the task-window: 
When i want to edit a task by rightclicking it, selecting 'edit task', nothing happens.
In the Error Console, i get the following error:

Error: uncaught exception: [Exception... "Could not convert JavaScript argument"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: chrome://calendar/content/calendar-item-editing.js :: createTodoWithDialog :: line 123"  data: no]
The problem is that http://lxr.mozilla.org/mozilla/source/calendar/resources/content/unifinderToDo.js#629 is called with the wrong set of arguments.
Whiteboard: [good first bug]
OS: Linux → All
Hardware: PC → All
Summary: edit task: nothing happens → Edit Task command from tasklist context menu does nothing
this is more or less copy paste from line 230, same file. It fixes it on my linux box.
Attachment #247580 - Flags: first-review?(jminta)
Comment on attachment 247580 [details] [diff] [review]
change from create to modify

Fantastic. r=jminta  Thanks for the patch!
Attachment #247580 - Flags: first-review?(jminta) → first-review+
Attachment #247580 - Flags: second-review?(mvl)
Comment on attachment 247580 [details] [diff] [review]
change from create to modify

Sorry, should have marked r2 for this as well.
Attachment #247580 - Flags: second-review?(mvl) → second-review+
Patch checked in.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061209 Calendar/0.4a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.