Closed Bug 362866 Opened 13 years ago Closed 13 years ago

Tasklist, unifinder and views still display old task/event after conversion to event/task

Categories

(Calendar :: Calendar Views, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: jminta)

Details

Attachments

(1 file)

Tasklist and views still display old task/event after conversion to event/task

Steps to Reproduce:
1. Start Sunbird with new profile
2. Create new event 'A' with default settings
3. Create a new task 'B' with default settings
4. Edit the event 'A' and convert to task via dropdown menu and save
5. Edit the task 'B' and convert to event via dropdown menu and save

Actual Results:
A is shown in task list (ok), calendar view (not ok) and unifinder (not ok).
B is shown in task list (not ok), calendar view (ok) and unifinder (ok).

Expected Results:
A is only shown in task list.
B is not shown in task list anymore. 
B is shown in calendar view only if 'Tasks in view' settings is enabled.
B is shown in unifinder if the filter matches the date range of the event.

After a forced refresh the events and task are displayed correctly.

Using Sunbird/0.4a1 (2006120509).
These are generally caused by the instanceof checks introduced for optimization purposes.
This patch tidies up a bunch of sloppy checks in various onModifyItem calls.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #247571 - Flags: second-review?(mvl)
Attachment #247571 - Flags: first-review?(lilmatt)
Comment on attachment 247571 [details] [diff] [review]
proper filtering in observers

r=lilmatt
Attachment #247571 - Flags: first-review?(lilmatt) → first-review+
Comment on attachment 247571 [details] [diff] [review]
proper filtering in observers

r2=mvl
Attachment #247571 - Flags: second-review?(mvl) → second-review+
Patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [litmus testcase wanted]
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061211 Calendar/0.4a1
Status: RESOLVED → VERIFIED
Flags: in-litmus?
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.