create release notes pages and project homepage for Firefox 2.0.0.1

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
12 years ago
6 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: baz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

missing the 2.0.0.1 "what's new" page

I see this when firing up 2.0.0.1 (after a nightly update)

I get a 404:

404: File Not Found

/projects/firefox/2.0.0.1/whatsnew/

*** This bug has been marked as a duplicate of 362555 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Component: www.mozilla.com → www.mozilla.org
OS: Windows XP → All
Product: Websites → mozilla.org
QA Contact: www-mozilla-com → www-mozilla-org
Hardware: PC → All
Version: unspecified → other
Er, wrong version. :(

This will be done when beltzner is ready.
Status: RESOLVED → REOPENED
Component: www.mozilla.org → www.mozilla.com
Product: mozilla.org → Websites
QA Contact: www-mozilla-org → www-mozilla-com
Resolution: DUPLICATE → ---
Summary: missing the 2.0.0.1 "what's new" page → create release notes pages and project homepage for Firefox 2.0.0.1
Version: other → unspecified
We never do the content until the very last minute. ;)
Assignee: nobody → beltzner
Status: REOPENED → NEW

Comment 5

12 years ago
Adding Pascal to the bug, as this has potential l10n impact.

Beltzner: is there anything major in 2.0.0.1 that we want to call out in the What's New page? If not, the easiest thing to do will be to copy over all the existing 2.0/firstrun and 2.0/whatsnew pages for each locale to corresponding 2.0.0.1/firstrun and 2.0.0.1/whatsnew directories.

Assignee: beltzner → basil
This is all being prepped for release tomorrow, so I'm marking this FIXED. Pages go live tomorrow at 10AM PST.
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Copies of the 2.0 folders content to 2.0.0.1 folders are on stage for all locales.

Comment 8

12 years ago
http://www.mozilla.org/projects/firefox/2.0.0.1/whatsnew/
is still 404.

http://www.mozilla.com/firefox/2.0.0.1/whatsnew/
is OK.

I am using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061218 BonEcho/2.0.0.1

Is this string Bon Echo only?

Comment 9

12 years ago
I am on dialup today and cannot do any further testing.  Seems to me the 404's should be fixed in any case, but here are my about:config values:

startup.homepage_override_url
default
string
http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/

startup.homepage_welcome_url
default
string
http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/

Comment 10

12 years ago
Why is it marked as fixed?

Yes, the "What's new" page was created; but it does not work because of redirection bug. Please correct it so that it redirects correctly.

http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/
%VERSION% = 2.0.0.1

The redirection thing was done with version checking (1.[05]|2.0). Unfortunately the what's new page after updating browser [0] does not work.

[0] http://www.mozilla.org/projects/firefox/2.0.0.1/whatsnew/
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.