Last Comment Bug 362938 - Attendee Dialog: No borders between days in free/busy grid
: Attendee Dialog: No borders between days in free/busy grid
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Dialogs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: 1.8
Assigned To: Richard Marti (:Paenglab)
:
:
Mentors:
: 411166 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 03:18 PST by Andreas Treumann
Modified: 2012-07-27 05:40 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (1.69 KB, patch)
2012-05-23 02:46 PDT, Richard Marti (:Paenglab)
philipp: review+
Details | Diff | Splinter Review
patch in action (4.81 KB, image/png)
2012-05-23 02:47 PDT, Richard Marti (:Paenglab)
no flags Details
Javascript changes - v2 (8.79 KB, patch)
2012-06-29 06:31 PDT, Philipp Kewisch [:Fallen]
no flags Details | Diff | Splinter Review
patch v2 (12.82 KB, patch)
2012-07-01 06:33 PDT, Richard Marti (:Paenglab)
philipp: review+
philipp: approval‑calendar‑aurora+
Details | Diff | Splinter Review
patch in action (31.89 KB, image/png)
2012-07-01 06:35 PDT, Richard Marti (:Paenglab)
no flags Details

Description Andreas Treumann 2006-12-06 03:18:44 PST
REPRODUCTION:
=============

- create a new event
- open the attendee dialog

RESULT:
=======

- there are no borders visible between different days visible

EXPECTED RESULT:
================

- see http://wiki.mozilla.org/Calendar:SMB_Event_Dialog_-_Invite_Attendee
- there are borders between displayed days


REPRODUCIBLE:
=============

- always
Comment 1 Andreas Treumann 2008-01-07 23:57:37 PST
*** Bug 411166 has been marked as a duplicate of this bug. ***
Comment 2 Mike Beltzner [:beltzner, not reading bugmail] 2008-01-29 17:12:37 PST
Oh, crap, sorry, moving back, send hatemail to this address.
Comment 3 Martin Schröder [:mschroeder] 2009-06-26 15:05:12 PDT
Dialog is also present in Sunbird -> Move to Calendar:General
Comment 4 Philipp Kewisch [:Fallen] 2012-05-21 17:57:48 PDT
Richard, another one for you maybe?
Comment 5 Richard Marti (:Paenglab) 2012-05-23 02:46:48 PDT
Created attachment 626377 [details] [diff] [review]
patch

All I can do is giving a border in the header to separate the days.

If a border is needed also below in the grid, then a JS function is needed to tag the last (or first) .freebusy-grid of a day to specially style this item with a border.
Comment 6 Richard Marti (:Paenglab) 2012-05-23 02:47:29 PDT
Created attachment 626378 [details]
patch in action
Comment 7 Philipp Kewisch [:Fallen] 2012-05-23 03:44:08 PDT
Can't you use the :first-child and :last-child pseudo-classes?
Comment 8 Richard Marti (:Paenglab) 2012-05-23 03:55:13 PDT
No, because the .freebusy-grid items are not grouped per day. The :first-child is the first in the row (totally on the left) and :last-child is the last on the right when you scroll to the right.
Comment 9 Philipp Kewisch [:Fallen] 2012-06-13 11:19:46 PDT
Comment on attachment 626377 [details] [diff] [review]
patch

Something like this should give you the needed classes (please ignore it being on comm-central, that was accidental and has been backed out):

http://hg.mozilla.org/comm-central/raw-rev/1e979716ff6a

On your screenshot the vertical lines have at least 1px offset if you compare header day lines and body lines. I can't test this ATM due to build issues.

If you want to try it with the JS changes, then be my guest. If not, then just push the patch you have (with offset fixed) and leave this bug open.
Comment 10 Richard Marti (:Paenglab) 2012-06-13 23:26:40 PDT
(In reply to Philipp Kewisch [:Fallen] from comment #9)
> On your screenshot the vertical lines have at least 1px offset if you
> compare header day lines and body lines. I can't test this ATM due to build
> issues.

I've fixed the line alignment locally.
No problem, the merge is far away. Let's check-in the patch in one piece.

> If you want to try it with the JS changes, then be my guest. If not, then
> just push the patch you have (with offset fixed) and leave this bug open.

I tried the JS change and it works partially:
- The first 'first-in-day' in the grid is on the second .freebusy-grid element. The
  next days are okay.
- I've never seen a 'last-in-day' element.
- first-in-day and last-in-day should also have the freebusy-grid. Then only the
  additional changes have to be added in CSS.
Comment 11 Philipp Kewisch [:Fallen] 2012-06-29 06:31:41 PDT
Created attachment 637886 [details] [diff] [review]
Javascript changes - v2

This patch was very nervewracking. I really need to overhaul the attendee dialog code at some point :-)

It should work now, both the grid and the time bar at the top have the first-in-day/last-in-day classes. Let me know if something doesn't work as expected.
Comment 12 Richard Marti (:Paenglab) 2012-07-01 06:33:56 PDT
Created attachment 638181 [details] [diff] [review]
patch v2

Philipp, thank you for the JS fixes.

This patch inserts a 2px space between days in title and on the rows on top. The empty rows have no border to separate the days because they have no freebusy-grid items in them.
Comment 13 Richard Marti (:Paenglab) 2012-07-01 06:35:27 PDT
Created attachment 638182 [details]
patch in action

Screenshot with Attendees list patch on Windows, Linux and Mac.
Comment 14 Richard Marti (:Paenglab) 2012-07-27 05:05:53 PDT
Philipp, have you any time to review this patch?

And can this land also on beta or aurora?
Comment 15 Philipp Kewisch [:Fallen] 2012-07-27 05:20:21 PDT
Comment on attachment 638181 [details] [diff] [review]
patch v2

r=philipp. I don't think we should take this down to beta, I'm not sure if there will be another beta before the release.
Comment 16 Richard Marti (:Paenglab) 2012-07-27 05:40:33 PDT
Pushed to comm-central: http://hg.mozilla.org/comm-central/rev/0cce91ac3be6
and comm-aurora: http://hg.mozilla.org/releases/comm-aurora/rev/84a77b11c96b

Note You need to log in before you can comment on or make changes to this bug.