Crash [@ nsPasswordManager::Init]

VERIFIED FIXED

Status

()

Toolkit
Password Manager
--
critical
VERIFIED FIXED
11 years ago
7 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: Martijn Wargers (dead))

Tracking

({crash, topcrash, verified1.8.0.10})

1.8.0 Branch
x86
Windows XP
crash, topcrash, verified1.8.0.10
Points:
---
Bug Flags:
blocking1.8.0.10 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs testcase], crash signature)

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
There seem to be quite a few crashes with the [@ nsPasswordManager::Init] stack on the 1.8.0.x branch.
It's the number 4 on the list of crashes in 1508:
http://talkback-public.mozilla.org/reports/firefox/FF1508/index.html

Talkback ID:
nsPasswordManager::Init  [mozilla/toolkit/components/passwordmgr/base/nsPasswordManager.cpp, line 290]
nsPasswordManager::GetInstance  [mozilla/toolkit/components/passwordmgr/base/nsPasswordManager.cpp, line 233]
CallCreateInstance  [mozilla/xpcom/build/nsComponentManagerUtils.cpp, line 171]
nsAppStartupNotifier::Observe  [mozilla/embedding/components/appstartup/src/nsAppStartupNotifier.cpp, line 102]
XRE_main  [mozilla/toolkit/xre/nsAppRunner.cpp, line 2205]
main  [mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x16fd7 (0x7c816fd7)
(Assignee)

Comment 1

11 years ago
It's crashing here:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/components/passwordmgr/base/nsPasswordManager.cpp&mark=290&rev=MOZILLA_1_8_0_BRANCH#290
So maybe this needs a similar protection, like in:
http://lxr.mozilla.org/seamonkey/source/toolkit/components/passwordmgr/base/nsPasswordManager.cpp#1568       
?
(Assignee)

Comment 2

11 years ago
Created attachment 247668 [details] [diff] [review]
Like this?

This is a patch for the 180x branch only.
It seems like this code changed in 1.8.1 branch and trunk builds, when bug 58724 was fixed. It has a similar protection, which I pointed out in my previous comment.
Attachment #247668 - Flags: review?(enndeakin)
(Assignee)

Updated

11 years ago
Version: unspecified → 1.5.0.x Branch

Updated

11 years ago
Attachment #247668 - Flags: review?(enndeakin) → review+
(Assignee)

Updated

11 years ago
Attachment #247668 - Flags: approval1.8.0.10?
(Assignee)

Updated

11 years ago
Flags: blocking1.8.0.10?
This is really a dupe of bug 294075, which was fixed on the trunk by bug 221634.
(Assignee)

Comment 4

11 years ago
Yeah, this is the same as bug 294075, that bug was never fixed on the 1.8.0.x branch.
Assignee: nobody → martijn.martijn
Flags: blocking1.8.0.10? → blocking1.8.0.10+
Comment on attachment 247668 [details] [diff] [review]
Like this?

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #247668 - Flags: approval1.8.0.10? → approval1.8.0.10+
(Assignee)

Comment 6

11 years ago
Checking in toolkit/components/passwordmgr/base/nsPasswordManager.cpp;
/cvsroot/mozilla/toolkit/components/passwordmgr/base/nsPasswordManager.cpp,v  <-
-  nsPasswordManager.cpp
new revision: 1.65.2.4.4.2; previous revision: 1.65.2.4.4.1
done

Checked into the 1.8.0.x branch.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.0.10
Currently this is Number 1 Top Crash on the 1508 Talkback Report. 

Is there any chance to get a Testcase for this ? Or do we need to wait for the Talkback Results after the 1510 Release ?
Whiteboard: [needs testcase]

Comment 8

11 years ago
Tomcat:  We will have to wait until we get more 1.5.0.10 Talkback data to confirm that it is no longer a topcrasher.  But, you can always use the Talkback query tool to see if there have been any crashes since the last release:

http://talkback-public.mozilla.org/search/start.jsp

If you enter "nsPasswordManager::Init" for the stack signature, select "Firefox15" as the product, and type in "2007" in the build id field, you will get crashes like this one for the 1.8.0 branch so far in 2007:
http://talkback-public.mozilla.org/search/start.jsp?search=1&searchby=stacksig&match=contains&searchfor=nsPasswordManager%3A%3AInit+&vendor=MozillaOrg&product=Firefox15&platform=All&buildid=2007&sdate=&stime=&edate=&etime=&sortby=bbid&rlimit=0

So it looks like we have not seen any crashes in the nightly builds on the 1.8.0 branch.  Not the best way to verify, since there aren't a lot of users testing that branch, but good enough for now.

v.fixed based on the latest Talkback data, but we will have to reconfirm that this crash is gone when we get more Firefox 1.5.0.10 Talkback data.
Keywords: fixed1.8.0.10 → verified1.8.0.10
verified fixed based on talkback data

also no crash with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a8pre) Gecko/2007083005 Minefield/3.0a8pre ID:2007083005
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
Crash Signature: [@ nsPasswordManager::Init]
You need to log in before you can comment on or make changes to this bug.