Cannot send email when email is copy of part of webpage incl image (copy from IE6 into thunderbird)

RESOLVED DUPLICATE of bug 204683

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 204683
12 years ago
11 years ago

People

(Reporter: bphupscher, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: version 1.5 Beta 1 (20050908)  - internet explorer 6.0

When I copy a piece of text and including some pictures from IE6 into new email from thunderbird, it does not correctly insert the pictures.
when then pressing send, it tries to attach the images, but never does, it remains trying for ever.

when copying from firefox into thunderbird it works ok i see,
when copying from firefox or IE6 into Outlook Express, there is no problem.

only problem is when copying from IE6 into thunderbird
I encountered this problem many times, when trying to send part of webpages, only to find today, that from firefox it is possible.


Reproducible: Always

Steps to Reproduce:
1. copy some text and picture from within the IE6
2. paste into Thunderbird email
3. press send  

Actual Results:  
does not send, just tries to attach the picture

Expected Results:  
that it would send the email incl picture

Comment 1

12 years ago
Please use the latest stable release (or preferably a nightly build) for reporting bugs.  Version 1.5 Beta 1 (20050908) isn't even a stable release. Can you reproduce using 1.5.0.8? If so, include the text you try to paste. 
(Reporter)

Comment 2

12 years ago
bug reproduced in version 1.5.0.8 (20061025)

Better Example 
OPEN with Internet explorer: http://www.mozilla-europe.org/en/products/thunderbird/

select with mouse:
"Junk Mail Filters
Each email you receive passes through Thunderbird's leading-edge junk mail filters. Each time you mark messages as spam, Thunderbird improves its filtering so you can spend more time reading the mail that matters. Thunderbird will also use your mail provider's spam filters to keep junk mail out of your inbox. 
 
IMAGE HERE(Thunderbird thinks...)
Anti-Phishing Protection"

past this all into thunderbird.
the image just above "Anti Phishing Protection" is not displayed,
and when send it keeps on looking for it.

If you copy this same piece from Firefox, and paste into thunderbird this problem is not there though. it only when selected and copied within Internet Explorer and then pasted into Thunderbird message
(Reporter)

Comment 3

12 years ago
Created attachment 247670 [details]
2 screenshots of bug in zip file

Comment 4

12 years ago
The reason this happens is: the image tag in the source file is:
  <img src="/img/en/phishing.png" alt="phishing alert" />
Note that the 'src' tag uses a relative path: it doesn't specify a domain.

Internet Explorer places a copy of that tag as it appears into the clipboard.
Firefox builds a copy of the selected HTML from its internal DOM representation of the page, which includes a fully-qualified path:
  <img src="http://www.mozilla-europe.org/img/en/phishing.png"
   alt="phishing alert">

When the compose window gets that pasted-in text, it tries to resolve 
/img/en/phishing.png to the only path it knows: the current workign directory on the local disk.  No image exists in that location.

There isn't anything that Thunderbird can do to fix the problem -- it doesn't know where that pasted buffer came from.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

11 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 204683
You need to log in before you can comment on or make changes to this bug.