Tabbing inside BookmarksOutlineView is broken

RESOLVED WONTFIX

Status

Camino Graveyard
Bookmarks
--
minor
RESOLVED WONTFIX
11 years ago
3 years ago

People

(Reporter: Chris Lawson (gone), Unassigned)

Tracking

({polish})

Details

(URL)

(Reporter)

Description

11 years ago
Normal NSTableViews and NSOutlineViews support tabbing from one cell to the next when you're in editing mode. Ours doesn't, and I can't for the life of me figure out why. This is going to be very noticeable once bug 175748 lands, so we should try to fix this soon if it's easy.
Ah, this is the bug I run across when I'm editing and hit tab to commit and go to the next cell and then can no longer load pages :/

I think this is the Console message I got; I can't create the error on demand :/

2007-05-31 15:37:21.754 Camino[19305] *** Assertion failure in -[_NSKeyboardFocusClipView setNextKeyView:], AppKit.subproj/NSView.m:4929
2007-05-31 15:37:21.755 Camino[19305] Exception raised during posting of notification.  Ignored.  exception: [NSView setNextKeyView:] to non-view object <%NSView: 0x6572da0>.  Make sure you hooked up the nextKeyView outlet to views, not cells, in InterfaceBuilder.
Target Milestone: Camino1.6 → ---
Mass un-setting milestone per 1.6 roadmap.

Filter on RemoveRedonkulousBuglist to remove bugspam.

Developers: if you have a patch in hand for one of these bugs, you may pull the bug back to 1.6 *at that point*.
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Probably ultimately a dupe of bug 411990.

Yeah, except that bug is 10.5-only and this one's been around since at least 10.4, at least if I'm understanding the other bug properly. (Or were you saying in the other bug that Safari, starting with 10.5, does the Right Thing™?)

cl
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.