If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

invalid EHLO command is sent in smtp session when TLS is used

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Bastian Schmitz, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Version 1.5.0.8 (20061025)

instead of sending the EHLO command, XXXX is sent.
logfile output with "NSPR_LOG_MODULES=smtp:5"

0[274608]: SMTP Connecting to: mail.statistik.uni-dortmund.de
0[274608]: SMTP entering state: 0
0[274608]: SMTP Response: 220 ************************************
0[274608]: SMTP entering state: 15
0[274608]: SMTP Send: EHLO [129.217.207.94]
0[274608]: SMTP entering state: 0
0[274608]: SMTP Response: 502 5.5.2 Error: command not recognized
0[274608]: SMTP entering state: 4
0[274608]: SMTP entering state: 12

this differs from output of
"ngrep host 129.217.207.94 and port 25" executed on the mail server:

T 129.217.206.4:25 -> 129.217.207.94:2086 [AP]
  220 mail.statistik.uni-dortmund.de ESMTP..
#
T 129.217.207.94:2086 -> 129.217.206.4:25 [AP]
  XXXX [129.217.207.94]..
##
T 129.217.206.4:25 -> 129.217.207.94:2086 [AP]
  502 5.5.2 Error: command not recognized..
####

captures by tcpdump show the same "XXXX" command, so i suppose the dumps are correct and thunderbird is lying in its logfile when writing "EHLO" was sent.
i verified this behaviour on windows xp and freebsd with thunderbird 1.5.0.8 .


Reproducible: Always

Steps to Reproduce:
1. set encryption setting in SMTP dialog to "TLS"
2. send mail


Actual Results:  
mail fails to send with error message:

An error occurred sending mail: Unable to connect to SMTP server mail.statistik.uni-dortmund.de via STARTTLS since it doesn't support EHLO. Please verify that your Mail/News account settings are correct and try again.

Expected Results:  
mail should be sent. 
thunderbird should send "EHLO" instead of "XXXX".
thunderbird should report correctly what was is sent in the logfile.

if you use the SMTP setting "TLS, if available", thunderbird also sends "XXXX" at first, and a "HELO" as a fallback. mail is transfered in clear text.
(Reporter)

Comment 1

11 years ago
sorry. bug is most likely caused by a misconfiguration of an inspecting firewall.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Summary: invalid EHLO command is sent via in smtp session when TLS is used → invalid EHLO command is sent in smtp session when TLS is used
You need to log in before you can comment on or make changes to this bug.