[TB-3a1] Invalid 'Size' display in 'Folder Sidebar'

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Nir, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

(Using TB-3a1 under Fedora core 5)

If you look at the screen shot , you will find that in the sidebar account name 'Earthlink' also assigned a   'size' 4kb which is completely impossible as Account name can't have any size. 

Reproducible: Always

Steps to Reproduce:
1.Goto Edit>Preferences>Advanced>General( in windows , Tools>options>Advanced>General ), check 'Expanded column in folder pane'
2.Select Account name , goto File>Compact folders to compact folders under that account


Actual Results:  
Account named is assigned with a size which is nor possible

Expected Results:  
Compacting will not assign that invalid 'size' to Account name.

1.I have tried to check whether this problem has caused by corrupted .msf files in my TB profile but after deletion of those .msf file 'still' this problem occurs.

2.This problem dis-appears if i restart TB but occurs again 'everytime' if I compact folders
(Reporter)

Comment 1

11 years ago
Created attachment 247874 [details]
Error In Size Display
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Updated

11 years ago
Summary: Invalid 'Size' display in 'Folder Sidebar' → [TB-3a1] Invalid 'Size' display in 'Folder Sidebar'
(Reporter)

Comment 2

11 years ago
It seems to me that This problem occurs only when I tries to compact ( file > compact folders ) when 'Account name' ( in my case 'Earthlink' ) is selected ( not folders )
(Reporter)

Comment 3

11 years ago
Created attachment 247958 [details]
Invalid Size Display In RSS account
(Reporter)

Comment 4

11 years ago
Created attachment 247959 [details]
Same for Local Folder
(Reporter)

Comment 5

11 years ago
An Additional Info.
This problem doesn't occurs in case of IMAP account.
(Reporter)

Comment 6

11 years ago
still same problem persist .
Deletion of .msf files can't fix it

Comment 7

11 years ago
I was not able to reproduce this - it's very odd that the sizes are all 4k. What happens if you delete panacea.dat and restart?
(Reporter)

Comment 8

11 years ago
(In reply to comment #7)
> I was not able to reproduce this - it's very odd that the sizes are all 4k.
> What happens if you delete panacea.dat and restart?
> 
Please note that "This problem dis-appears if i restart TB but occurs again 'everytime' if I
compact folders"

I have closed TB completely , deleted 'panacea.dat' file .
restarted TB. 
View normal ( as expected after restart )
Select account name , File > Compact folder
No error occurs

but if i disable and re-enable 'Expanded column in folder pane' option and compact again this error comes back again with same characteristic .
should i upload 'panacea.dat' file?

Comment 9

11 years ago
no, if the problem disappears when you restart, then I don't think it's a problem with panacea.dat - do you have any extensions installed? Anything on the js console?
(Reporter)

Comment 10

11 years ago
(In reply to comment #9)
> no, if the problem disappears when you restart, then I don't think it's a
> problem with panacea.dat - do you have any extensions installed? Anything on
> the js console?
> 

Same behaviour in safe mode.

un-installed all extensions ( except 'Talkback' ), using default Theme
Now started in safe mode 
tried to compact while selecting account name
Same problem occur

I'm using some chrome edit to customize folders and account name . does it can conflict with 'Size view' , although it doesn't have any code to customize 'size' view

Comment 11

11 years ago
no idea, but that makes me suspicious. No one else has ever reported this problem, though most users don't use the size column, I'm sure.
(Reporter)

Comment 12

11 years ago
before going for compact folder only message in javascript console (under 'all' view):
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIIOService2.manageOfflineStatus]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///usr/thunderbird/components/offlineStartup.js :: anonymous :: line 94"  data: no]
Source File: file:///usr/thunderbird/components/offlineStartup.js
Line: 94

no new message occurs after compact folder.
(Reporter)

Comment 13

11 years ago
(In reply to comment #11)
> no idea, but that makes me suspicious. No one else has ever reported this
> problem, though most users don't use the size column, I'm sure.
> 

That's right , many user don't like to waste space in folder pane ( including myself  ;) )
also please note : This problem doesn't occurs in case of IMAP account.
(Reporter)

Comment 14

11 years ago
Can't reproduce this bug 'version 3.0a1pre (20070616)' , marking as fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.