Extra separator on mail context menu

RESOLVED FIXED in seamonkey1.1final

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Krang, Assigned: Krang)

Tracking

({fixed-seamonkey1.1, regression, useless-UI})

1.8 Branch
seamonkey1.1final
x86
Windows XP
fixed-seamonkey1.1, regression, useless-UI

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

1.37 KB, patch
Ian Neal
: review+
neil@parkwaycc.co.uk
: superreview+
Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com]
: approval-seamonkey1.1+
Details | Diff | Splinter Review
(Assignee)

Description

12 years ago
When right-clicking on an email address within an email message body, the context menu that appears has an extra separator on top.  Please see the URL for a screenshot.  This bug has been confirmed on SeaMonkey 1.1 and 1.5 nightlies.
(Assignee)

Comment 1

12 years ago
Created attachment 247943 [details] [diff] [review]
Patch to remove separator

Here is a patch that removes the special cases for mailto: links when adding the edit separator.  According to bug 235577, those were originally there because TB apparently has a "Select All" item in the context menu for mailto: links, hence the need for an extra separator.  Since we don't, it's safe to remove them.
Assignee: mail → neuos
Status: NEW → ASSIGNED
Attachment #247943 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 2

12 years ago
(In reply to comment #1)
> TB apparently has a "Select All" item in the context menu for mailto:
> links, hence the need for an extra separator.  Since we don't,

Correction: SeaMonkey used to have "Select All" on that menu as well (and still does in 1.0.x releases), but I think it was removed as a result of the spellcheck patch (see suite/common/nsContextMenu.js, line 279).  Another approach to fixing this bug would be to add that item back to the menu, but that would depend on whether or not it is supposed to be there.

Comment 3

12 years ago
Comment on attachment 247943 [details] [diff] [review]
Patch to remove separator

Hiding the separator is the right way to go, we don't have "Select All" on other links so shouldn't for mailto links either.
Attachment #247943 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 4

12 years ago
Comment on attachment 247943 [details] [diff] [review]
Patch to remove separator

Thanks for the r+.  Requesting sr.
Attachment #247943 - Flags: superreview?(neil)

Updated

12 years ago
Attachment #247943 - Flags: superreview?(neil) → superreview+

Comment 5

12 years ago
[P.S. I preferred Paradigm K]
(Assignee)

Comment 6

12 years ago
Comment on attachment 247943 [details] [diff] [review]
Patch to remove separator

Thanks for the sr+, Neil.  Requesting branch approval.

(In reply to comment #5)
> [P.S. I preferred Paradigm K]

It did have somewhat more of a professional sound to it, but I have been phasing out that SN for various reasons.  Long story...
Attachment #247943 - Flags: approval-seamonkey1.1?
(Assignee)

Updated

12 years ago
Whiteboard: [checkin needed]
mozilla/mailnews/base/resources/content/mailContextMenus.js 	1.60
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]

Comment 8

12 years ago
Comment on attachment 247943 [details] [diff] [review]
Patch to remove separator

sounds good to me, first-a=me for 1.1, one still needed to go
Attachment #247943 - Flags: approval-seamonkey1.1? → approval-seamonkey1.1+
Checked in on branch.

Neuos, if possible, please create patches with "cvs diff" so they're a little easier to apply.
Keywords: fixed-seamonkey1.1
You need to log in before you can comment on or make changes to this bug.