video attachment from mail could not be played directly in Media Player

NEW
Unassigned

Status

MailNews Core
Attachments
11 years ago
2 years ago

People

(Reporter: zetka, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Workaround Comments #6+7)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061030 SeaMonkey/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.8) Gecko/20061030 SeaMonkey/1.0.6

In case of having attachment with video (example Happy New Year.wm), when clicking to the attachment file icon, it opens white window with adress:
mailbox:///I|/Program%20Files/Netscape/Mail/192.168.1.253/Inbox?number=641109452&part=1.2&type=video/x-ms-wm&filename=Happy%20New%20Year.wm
opens the media player, but it writes an error:
(I translate it from czech) something that supported protocol is not supported...
and in extended error information it speaks about error:
Error ID = 0xC00D11BB, Condition ID = 0x00000000.

I have to save the file directly to Desktop or somewhere, from where it can be without problems by clicking to its icon played. I think that Sea Monkey sends parameters for starting WMP not correctly.


Reproducible: Always

Steps to Reproduce:
1.have an email with attachment (*.wm)
2.open email and click to its icon in attachment window
3. get the error

Actual Results:  
WMP opens with errors, another opened WMV file started with:
mailbox:///I|/Program%20Files/Netscape/Mail/192.168.1.253/Inbox?number=625038112&part=1.2&type=video/x-ms-wmv&filename=big_laptop.wmv
gives an error that the file has a schema not recognized with WMV.
After question to start it leads to the same error.

Comment 1

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061211 SeaMonkey/1.0.7

I can consistently reproduce this behavior, as described, when both the SM browser & mail client are active when attempting to play the attachment.

POSSIBLY related to FireFox bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=280600

Invalid path with %20 (spaces) is passed to both the browser & WMP. Neither recognizes the path & attachment fails to play.

If only the mail client is active, the attachment is extracted to %Temp% and %Temp%\video.wmv successfully plays in WMP. No blank browser window is spawned.

Comment 2

11 years ago
I have the same problem.  

If it can be of any help, the exact message from WMP is : "Windows Media Player cannot play the file because the specified protocol is not supported. If you typed a URL in the Open URL dialog box, try using a different transport protocol (for example, "http:" or "rtsp:")."

Even if I chose "Open file with Windows Media Player" in the preferences, Mozilla will attempt to handle the file itself and will end up passing it to WMP when the browser is active.  When the browser is NOT active, the mail client will use WMP to open the file directly.

Comment 3

10 years ago
Reproduced with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4 and Windows Media Player 10. Opening the attachment starts WMP as external application. After confirming a dialog "The selected file has a scheme that is not recognized by WMP but the player may be able to play it" the error message appears as stated in comment #2 with the browser window active.

The problem seems to be related to the WMP plugin. MIME types are apparently considered to be handled internally if a plugin for them exists, which causes similar issues as those discussed in bug 58554 for other content types. Thus, explicit helper applications for video/x-ms-wmv or other video types assigned to the plugin are ignored. When temporarily disabling the "npdsplay.dll" plugin, attachments are correctly opened with the WMP as external application, following the specified Windows File Type associations. This points to the plugin handling as a likely cause or contributor for the issue. Obviously, permanently disabling the plugin is not an acceptable fix for this bug.

Comment 4

10 years ago
Confirming this for trunk and branch. Even though this is related to bug 58554, it's not exactly the same. A plug-in handler must be defined for this to occur, file types associated to WMP but not handled by the plug-in are not affected. The workaround suggested in bug 272524 comment #2 to enable plug-ins for Mail & Newsgroups does not resolve the issue. This only happens with e-mail attachments, not with links in web pages. Also, this occurs with either inline or attachment disposition. It doesn't matter whether the message is located on a remote IMAP folder or in one of the local folders, thus it's not a download issue either.

Assigning this to Mailnews: Attachments (implies Core, with only SeaMonkey being affected), alternative categories would be Plug-ins or File Handling.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032801 SeaMonkey/2.0a1pre
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9
Assignee: general → nobody
Status: UNCONFIRMED → NEW
Component: General → MailNews: Attachments
Depends on: 58554
Ever confirmed: true
Product: Mozilla Application Suite → Core
QA Contact: general → attachments
Version: unspecified → Trunk
(Reporter)

Comment 5

10 years ago
It seems, that nothing has changed. The SeaMonkey 1.1.9 does the same problem unchanged. I think that this error is very annoying for me, most of the short videos I receive by emails are in WM form. Does anybody take care about it?

Comment 6

10 years ago
zetka, I have confirmed the bug as I could reproduce it in both the current release and the nightly trunk builds. Thus, the bug is recognized as such, but somebody will have to take it now and work on a solution.

The current workaround is to disable the plugin as described in comment #3, e.g., by searching for "npdsplay.dll" and renaming it not to end in ".dll".

Comment 7

10 years ago
P.S.: A somewhat less absolute option to disable the WMP plugin is to set the plugin.scan.WindowsMediaPlayer preference to a value higher than your current WMP version (e.g., from 7.0 to 13.0) in about:config - this will disable it for SeaMonkey but not for any other application.
Whiteboard: Workaround Comments #6+7
(Reporter)

Comment 8

10 years ago
Maybe another comment- I have played with the problem on two different computers with the same newest seamonkey with following results.

On the first computer after installing the original Microsoft plugin for Netscape the problem went away immediately and the opening of the .wm works.
On the second computer it was different. After installing of the same plugin, a new window appeared with a message mailbox:// and there address of the source inbox file. Tried to rename the ndsplay.dll, no change. Then changed the item in about:config to version 13, renamed back the ndsplay.dll and after that after opening the mail attachment a correct window with selection appeared- which program I would like to use for opening the file, added the Microsoft media player and whoops - it opened the attachment correctly.
On this computer the main difference was, that there was a Nero Showtime installed and it associated most video files to it.

Maybe that helps by resolving the problem...
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Updated

2 years ago
See Also: → bug 898407
You need to log in before you can comment on or make changes to this bug.