text striked on misclosed strong tags

RESOLVED INVALID

Status

()

--
trivial
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: francesco.monte, Assigned: mrbkap)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061207 BonEcho/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061207 BonEcho/2.0.0.1

if you insert a string like:
 <strong>foo bar<s/trong>

the text following that, it's bold (of course, the tag is not closed..) and.. striked!

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Created attachment 247967 [details]
testcase

Updated

12 years ago
Keywords: testcase

Updated

12 years ago
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.8 Branch
Assignee: nobody → mrbkap
Component: General → HTML: Parser
OS: Windows XP → All
QA Contact: general → parser
Hardware: PC → All
Version: 1.8 Branch → Trunk
(Assignee)

Comment 2

12 years ago
(In reply to comment #0)
> if you insert a string like:
>  <strong>foo bar<s/trong>

Consider the <s/trong>. The HTML parser has to stop parsing the tag name at the / because of constructs like <br/>. Because of this, instead of seeing a close tag, we see: <s /trong> and ignoring the strange attribute '/trong', an open tag <s>, which starts strikethrough, which you don't have a close tag for.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.