Unnecessary case sensitivity in anchor tags

RESOLVED DUPLICATE of bug 241063

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 241063
11 years ago
11 years ago

People

(Reporter: chris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

The above link contains an anchor tag which is technically correct but contains incorrect case.  The link that Firefox recognizes is https://sales.sciencenorth.ca/#ameagan .  This seems to be an issue regarding anchor tags and case sensitivity, as many web designers aren't concerned with maintaining perfect case sensitivity.

Reproducible: Always

Steps to Reproduce:
1. Surf to a page with an anchor (#) link.  eg. http://test.com/index.html#test
2. Change the case of one or more letters in the anchor in the URL bar or in the actual website link.  eg. http://test.com/index.html#TeSt

Actual Results:  
If the case is not correct, anchor tags will not be followed.

Expected Results:  
Anchor tags should be followed regardless of case.

*** This bug has been marked as a duplicate of 241063 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.