incorrect layout leaves loads of whitespace

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: pfortin, Assigned: karnaze)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14 i686)
BuildID:    2000041811

The page's "Features" section should occupy the upper-right portion of the
"Breaking News" section.  Instead, it appeared in the upper-left and forced the
news items to be width-limited leaving over half of the area blank.

Tried to reproduce it in a new window; but it appeared OK this time.

Aside:  I will open several other bugs shortly because I was unable to use M15
to report this bug.

Reproducible: Couldn't Reproduce
(Reporter)

Comment 1

19 years ago
Hmmm...  visiting this site also triggers bugs 36324 and 36329

Comment 2

19 years ago
Looks to be table related
Assignee: troy → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → chrisd
(Reporter)

Comment 3

19 years ago
This is randomly reproducible.  I've not yet found the trigger.  

WOW!!  this site is doing lots of really strange stuff to the browser...

1. opened browser
2. double-clicked URL and typed www.inforworld.com<return>
3. text from the site displayed; but no graphics.
   The horiz scroll bar is about 3/4" above where it should be
4. waited...  still no graphics and page loading is done.
   The text is where I expect to see it
5. clicked on vert scroll bar to see the rest of the page...
At this point, all graphics popped into place and the "Features" warped to the
upper left of the "Breaking News" section forcing all news text to be
constrained to the left half of that area...  
(Reporter)

Comment 4

19 years ago
More info...  when I added the previous comments last night, only images in the
main frame had appeared.  The 3/4" offset was correct as I discovered this
morning when I switched to that desktop forcing a redraw of the window; this
area of the window now contains an image (verified with NS4.72).  It appears
that the images were only displayed one frame per window redraw...

Comment 5

19 years ago
 I can reproduce this bug under a May 2nd CVS build on Linux.
You need to start from a fresh browser session; it looks like
once Mozilla has had a chance to know the sizes of things (I
suspect inlined graphics) it will lay things out correctly.

 The easiest reproduction:
- start Mozilla, showing http://www.infoworld.com/
- Observe that the Features box is in the top left of
  the main 'Breaking News' section.
- use View | Enlarge Text Size.
- 'Features' box jumps to the right, and text gets
  pulled up on the left.
- use View | Reduce Text Size to bring things back
  to the original state.
- 'Features' box stays as it is.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

19 years ago
In case this helps, here is the log from Amaya3.1 (http://www.w3.org/Amaya/)
which has a tougher time displaying this page:

*** Errors in http://www.infoworld.com/pageone.html temp file:
/home/pfortin/.amaya/1/pageone.html
   line 3, char 321: Invalid attribute "COLS"
   line 5, char 9: Unknown tag <nolayer>
   line 5, char 24: Invalid attribute "border"
   line 5, char 126: Invalid attribute "noscroll"
   line 5, char 505: Unknown tag </nolayer>
   line 5, char 513: Unknown tag <ilayer>
   line 5, char 519: Invalid attribute "width"
   line 5, char 532: Invalid attribute "height"
   line 5, char 548: Invalid attribute "visibility"
   line 5, char 564: Unknown tag </ilayer>
   line 67, char 165: Invalid attribute "COLS"
   line 85, char 168: Unknown attribute value "align = center"
   line 88, char 311: Unexpected end tag </a>
   line 131, char 90: Invalid entity "&T "
   line 163, char 126: Invalid entity "&sid"
   line 234, char 241: Unknown attribute value "align = CENTER"
   line 234, char 306: Invalid attribute "VALIGN"
   line 265, char 43: Unknown attribute value "valign = center"
   line 268, char 42: Unknown attribute value "valign = center"
   line 296, char 85: Invalid attribute "VALIGN"
   line 376, char 30: Unknown tag <layer>
   line 376, char 37: Invalid attribute "onload"
   line 376, char 85: Invalid attribute "visibility"
   line 376, char 96: Invalid attribute "src"
   line 376, char 208: Unknown tag </layer>
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Comment 7

19 years ago
I am not able to reproduce the problem using the instructions in the 2000-05-03 
00:46 comments. The Features box is in the correct location of the main 
'Breaking News' section.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 8

18 years ago
Adding 'verifyme' keyword
Keywords: verifyme

Comment 9

18 years ago
Verified worksforme with Mac, Linux and WinNT branch builds 10/3.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.