When I point the mouse to a link to a bug, show me a tooltip with the bug description

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
12 years ago
9 years ago

People

(Reporter: jasonspiro4, Unassigned)

Tracking

Details

(Whiteboard: [bz_extension])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Bugzilla Version 2.20+

When I point the mouse to a link to a bug, it would be great if Bugzilla showed me an AJAX-based tooltip with the bug summary and description.

See http://en.wikipedia.org/wiki/Wikipedia:Tools/Navigation_popups for a screenshot of Wikipedia's AJAX popup tool. Try it; it will give you inspiration :). For help installing it, ask in freenode channel #wikipedia.


Reproducible: Always

Comment 1

9 years ago
It seems pretty straight forward to do a simple summary tooltip for links to bugs. how about that?

Comment 2

9 years ago
The request is to take the information which is in the title and turn it into something fancier, like an AJAX tooltip. 

Currently there is a filter in Bugzilla which will create a link and add the summary information to the title based on a bug number, it even checks the user permissions etc, it's kinda fantastic. 

This is a neat idea for an extension but totally not needed as part of core Bugzilla.  Closing won't fix but adding the bz_extension to the whiteboard.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Whiteboard: [bz_extension]

Comment 3

9 years ago
Hum, the request is to include the bug description, aka comment 0, not only the bug summary. |FILTER bug_link | doesn't do this.

Comment 4

9 years ago
That doesn't seem wise since we know that comment 1 is often not a very good or useful description of the problem. I might work on this as an extension to show of some of the JSONP stuff that Max has worked on. But I'm not sure when that day will come.

This bug should block on bug 262087, however, the bug that links to it has Frederic stating that users can just use a custom field for this purpose, so I might implement it as both a JSONP/Description custom field creation. We'll see. BTW anyone can make extensions so feel free to implement it if you're reading this.
You need to log in before you can comment on or make changes to this bug.