[FIX]combobox in centered table not displaying

VERIFIED FIXED in M16

Status

()

P2
major
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: andre, Assigned: rods)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][dogfood-], URL)

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
tested on: 2000-04-18-05/win2000	
reproduceable always

1. load the above URL
2. that document validates for W3C HTML4.0 and W3C CSS
3. it looks fine in IE5
4. mozilla fails do display two tables inside the fieldset
5. i really did not find any faults, that should not occur

Comment 1

19 years ago
this sounds like a layout bug
Assignee: asadotzler → troy
Component: Browser-General → Layout
QA Contact: jelwell → petersen
(Reporter)

Comment 2

19 years ago
i tested a bit and it seems that it depends on the content of the select box
(there are many option fields inside)
I created to other files, the first one with the equal "option tags"
the second one saved with IE and uploaded as .html file, first one does not
fail, second one fails too, but different than the original file
(Reporter)

Comment 3

19 years ago
second file works too, I cannot provide additional files because mozilla
displays them correctly now, the original file still is buggy

Comment 4

19 years ago
I'm hitting an assert in the nsFrame::AppendFrames() code. That code should 
never be reached, because nsFrame is a leaf frame and so it should not be having 
child frames appended

Eric, it looks like the fieldset frame doesn't handle AppendFrames()?
Assignee: troy → evaughan
(Reporter)

Comment 5

19 years ago
Hmm, I think I did not mention it clearly, if you change the content of the
select tags, the other tables will be displayed,
you should have a look at
http://rk-online.itbnet.de/shop/rk_simplified.html (working)
http://rk-online.itbnet.de/shop/rl.htm (working too, was buggy one or two times)
(Reporter)

Comment 6

19 years ago
exactly the same page is working with the ending .htm
http://rk-online.itbnet.de/shop/rk_.htm
I think it could have something to do with the delay that occurs on loading the
.php3 page, the html page is static and the php page first has to execute some
database queries,
perhaps mozilla does not want to wait until all queries are finished and starts
displaying the file, but then forgets to update it after retrieving the next
html fragments
Confirming.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

19 years ago
All these examples now work in my build. Well check in soon.
Status: NEW → ASSIGNED
Whiteboard: fixed will checkin soon

Comment 9

19 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: fixed will checkin soon
(Reporter)

Comment 10

19 years ago
cannot verify with build 2000-05-15-08 /win32 (tried URL)
will test again tomorrow
(Reporter)

Comment 11

19 years ago
cannot verify again, perhaps some of you (developers) should test mozilla
WITHOUT a high-bandwidth connection
and even offline, mozilla does not perform very good at small-bandwidth
connections or offline (hangs sometimes)
, back the topic, this bug is still present using 2000-05-17-08, I´ve tried out
the above URL from an
64k ISDN line
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

19 years ago
confirmed that this is still a problem.  the combobox does not appear.  but, the 
combobox *IS* really there.  If you dump frames, you'll see it in the right 
place.  And if you click where it's supposed to be, the list will actually drop 
down.

cc-ing rod.

aboud to attach the test case (not reduced yet, sorry.)

Comment 13

19 years ago
Created attachment 9098 [details]
original test case

Comment 14

19 years ago
Created attachment 9099 [details]
minimized test case

Comment 15

19 years ago
this has nothing to do with eric, the fieldsets were irrelevant.  assigning to 
myself.
Assignee: evaughan → buster
Status: REOPENED → NEW
Summary: moz fails displaying all tables!!! → combobox in centered table not displaying

Comment 16

19 years ago
nominating as dogfood, since it makes any page with this pattern unusable
Severity: critical → major
Status: NEW → ASSIGNED
Keywords: dogfood
Priority: P3 → P2
Target Milestone: --- → M17

Comment 17

19 years ago
here's the problem:
nsLineLayout has this code, which is correct:

aFrame->Reflow(mPresContext, metrics, reflowState, aReflowStatus);
aFrame->GetFrameState(&state);
if (NS_FRAME_OUTSIDE_CHILDREN & state) {
  pfd->mCombinedArea = metrics.mOverflowArea;
}
else {
  pfd->mCombinedArea.x = 0;
  pfd->mCombinedArea.y = 0;
  pfd->mCombinedArea.width = metrics.width;
  pfd->mCombinedArea.height = metrics.height;
}

in this case, aFrame is the combobox.  the combobox is returning the correct 
values in metrics for width and height, but it has set mOverflowArea to 
(0,0,0,0), and it has the NS_FRAME_OUTSIDE_CHILDREN state bit set.  So either 
the combobox shouldn't have this bit set after this reflow, or it should be 
setting mOverflowArea in the nsHTMLReflowMetrics metrics struct.
Assignee: buster → rods
Status: ASSIGNED → NEW

Comment 18

19 years ago
Created attachment 9108 [details]
simpler-yet test case, just a select with a width in a centered table
(Assignee)

Comment 19

19 years ago
So how or why is the NS_FRAME_OUTSIDE_CHILDREN flag getting set for the 
combobox? The cbx isn't setting it. What exactly does that flag mean?
Status: NEW → ASSIGNED
(Assignee)

Comment 20

19 years ago
*** Bug 39425 has been marked as a duplicate of this bug. ***

Comment 21

19 years ago
Putting on [nsbeta2+][dogfood-] radar.  Does not need a fix ASAP for daily work, 
but we should fix this for beta2.
Whiteboard: [nsbeta2+][dogfood-]
(Assignee)

Updated

19 years ago
Summary: combobox in centered table not displaying → [FIX]combobox in centered table not displaying
(Assignee)

Updated

19 years ago
Target Milestone: M17 → M16
(Assignee)

Comment 22

19 years ago
fixed it.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 23

19 years ago
Fixed in the June 1 builds.
Status: RESOLVED → VERIFIED
Adding keyword to bugs which already show a nsbeta2 triage value in the status 
whiteboard so the queries don't get screwed up.
Keywords: nsbeta2
You need to log in before you can comment on or make changes to this bug.