Closed Bug 363263 Opened 15 years ago Closed 15 years ago

Cross building may lead to bad OS target and extensions uninstallability

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glandium, Assigned: glandium)

Details

Attachments

(1 file)

When installing extensions which come with a target platform, the value of nsIXULRuntime.OS is compared to the target platform indicated in install.rdf.

The problem is nsIXULRuntime.OS is set from OS_TARGET, which is different if you cross compile.

When you cross-compile, you give a target to configure that is different from the host. But both are supposed to be strings like what config.guess returns, such as  i686-pc-linux-gnu. In such case, OS_TARGET gets a linux-gnu value, which is very different from the Linux value it gets when not cross-compiling.

I'm going to attach a simple patch for that issue.
Attached patch PatchSplinter Review
This fixes the issue for Linux. I don't know if there are similar issues with other targets.
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Attachment #248069 - Flags: review?
Attachment #248069 - Flags: review? → review?(bsmedberg)
Also note that this issue is kinda linked to bug #343975, because the values set for OS_TARGET and friends are taken from uname instead of ${host_*} variables.
Comment on attachment 248069 [details] [diff] [review]
Patch

Whoops, you used my watcher email for a request, so that it doesn't end up in my queue. Please make sure to use benjamin@smedbergs.us in the future ;-)
Attachment #248069 - Flags: review?(bsmedberg) → review?(benjamin)
Comment on attachment 248069 [details] [diff] [review]
Patch

This looks good. We should really file a bug to get rid of one of OS_ARCH or OS_TARGET, since they are approximately the same.
Attachment #248069 - Flags: review?(benjamin) → review+
Fixed on trunk.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Flags: in-testsuite-
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.