{inc}anonymous table object construction splits row groups when content arrives in pieces (display:table)

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: dbaron, Assigned: bzbarsky)

Tracking

({testcase})

Trunk
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

When the contents of a display:table that should have a set of anonymous table objects (row group, row, cell) inside of it arrive in two chunks from the network because the page is large, or if there's a script that forces layout in the middle of the contents, multiple anonymous table objects end up being created where only a single one should have been.

I simplified this testcase http://nyslittree-org.advantex.net/index.cfm/fuseaction/DB.ListNYSAuthors.cf which was posted to the css-d mailing list today.

Steps to reproduce: load attached testcase

Expected results: "one" and "two" should be vertically at the same position.

Actual results: "two" ends up a "line" lower than "one", because it's been put in a separate anonymous row-group, row, and cell even though it should have been in the same ones.

Comment 2

12 years ago
I would say this is a dupe of bug 148810.

The current plan of attack is to get rid of TableProcessChild  via bug 243159 and then to make the pseudos sane, thats at least how I understand bz's comments.

Part of the work has stalled in bug 162063.

Updated

10 years ago
Keywords: testcase
Yeah, this got fixed by the checkin for bug 148810.  I've added a reftest: http://hg.mozilla.org/mozilla-central/rev/c7018b3ca941
Assignee: nobody → bzbarsky
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 148810
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.