Closed Bug 363367 Opened 14 years ago Closed 13 years ago

[reflow branch] Unaccounted transparent line inside of the border when using border-collapse

Categories

(Core :: Layout, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: coth, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1

An unaccounted transparent line appears inside of the border in the table, when table using border-collapse: collapse.

Reproducible: Always

Steps to Reproduce:
1. make a simple code with the table with collapsed cellspacing, borders and with hover effect for background and for border.

Actual Results:  
see the thin line at the right of the table.

Expected Results:  
table should be fully filled, but it's not.
Attached image thin line screenshot
Works in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch) (box is totally red on hover)

Broken in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch) (box has gap at right hand side on hover)
Keywords: regression
Summary: Unaccounted transparent line inside of the border when using border-collapse → [reflow branch] Unaccounted transparent line inside of the border when using border-collapse
Status: UNCONFIRMED → NEW
Ever confirmed: true
The hover effect is not needed. The background of the table leaves a 1px space on the right.

This happens only in quirks mode, btw.
Looks like this was fixed at some point, I don't see any line there. -> WORKSFORME
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.