Closed Bug 363375 Opened 14 years ago Closed 12 years ago

[cocoa] cocoa keybindigs ignored in all text boxes

Categories

(Firefox :: Keyboard Navigation, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 282097

People

(Reporter: is+mozilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9.a1) Gecko/20061204 GranParadiso/3.0a1

I use ~/Library/KeyBindings/DefaultKeyBinding.dict to enable the better part of the Emacs keybindings in my cocoa text widgets. However, other than ctrl-[aekw], it seems that none of the works in the new cocoa-enabled Gran Paradiso. They do work in Camino. 

Reproducible: Always

Steps to Reproduce:
1. Edit keybindings; start Gran Paradiso
2. focus any text box
3. hit C-t, M-d, M-w, or basically any special other than the one above

Actual Results:  
Firefox beeps at me.

Expected Results:  
Executed the appropriate text function.
This may have been fixed by Bug 355817, but a lot of keyboard stuff is broken right now.
duplicate of 282097
(In reply to comment #2)
> duplicate of 282097

Yes.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 282097
You need to log in before you can comment on or make changes to this bug.