Closed Bug 363381 Opened 13 years ago Closed 10 years ago

Testcase with textarea inside form element extremely slow to render when spellcheck is enabled

Categories

(Core :: Spelling checker, defect, critical)

x86
Windows 2000
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: stevee, Unassigned)

References

()

Details

(Keywords: hang, regression, testcase)

This was found whilst trying {inc} bugs after the reflow branch landing.
The testcase (see URL) in bug 166397 causes the browser to freeze/hang for a length of time. Eventually the page is rendered, but as soon as you try and scroll it, firefox will freeze for time again.

It seems that the freeze only happens when the browser is redrawing the textarea that is inside the form element of the testcase.

Works:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.1) Gecko/20061210 BonEcho/2.0.0.1 ID:2006121003
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060703 Minefield/3.0a1 ID:2006070304 [cairo]

Freezes:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060704 Minefield/3.0a1 ID:2006070404 [cairo]

Bonsai regression range:
- http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-07-03+03%3A00%3A00&maxdate=2006-07-04+05%3A00%3A00&cvsroot=%2Fcvsroot
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061209 Minefield/3.0a1 ID:2006120913 [cairo]
With the latest trunk (post-reflow) the page is initially drawn much quicker (opposed to staying white and gradually bits being drawn) but it still freezes the browser.
So this problem seems to have been exposed by bug 339066. (Thanks to RyanVM for the hint!)

When I set layout.spellcheckDefault to 0 the hanging/freezing goes away.

However, bug 339066 landed on the branch too, and the branch doesn't show the hanging, so I guess bug 339066 has exposed another bug.

Any ideas where I can go from here?
Summary: Testcase with textarea inside form element extremely slow to render → Testcase with textarea inside form element extremely slow to render when spellcheck is enabled
Product: Firefox → Core
QA Contact: general → general
Assignee: nobody → mscott
Component: General → Spelling checker
QA Contact: general → spelling-checker
Keywords: hang
Severity: normal → critical
We're hanging while painting text decorations. This is because text decoration painting sucks with the current text frame. I think this will be fixed by the new text frame.
Depends on: 333659
This problem is now much reduced. Although now scrolling is pretty slow, the hanging has gone.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a6pre) Gecko/2007062004 Minefield/3.0a6pre (pre-textframe landing)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a6pre) Gecko/20070620 Minefield/3.0a6pre ID:2007062013 (post-textframe landing)

Strangely, the hanging behaviour disappeared before the text-frame landing, as both the above builds do not show the hanging I was seeing on earlier trunk builds.

WORKSFORME?
Assignee: mscott → nobody
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090615 Firefox/3.5 (.NET CLR 3.5.30729). Resolving.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.