Thunderbird doesn't show all messages in folder

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: cyx, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Thunderbird version 3 alpha 1 (20061210)

Thunderbird fails to show all messages on certain folders. This hapened on 1.5 and still happens on 3.0a1 (20061210)

Reproducible: Always

Steps to Reproduce:
1. create folder with enclosed mail file (on next message)
2. open folder
3. see that the file contains 2 messages, yet Thunderbird shows only one.

Actual Results:  
Thunderbird shows one message on the folder. The second seems to be ignored.

Expected Results:  
There are two messages to be shown.
(Reporter)

Comment 1

12 years ago
Created attachment 248212 [details]
problematic mail file

this is a mail file where the second message appears to be ignored by Thunderbird.

Comment 2

12 years ago
the second one is deleted - the x-mozilla-status line is 0x0008, which means it has been deleted. Did it arrive that way, or did you or a message filter delete the message?
(Reporter)

Comment 3

12 years ago
there is no mail filter set to delete anything anywhere. The message appears for a moment the first time I look at the folder and then it's gone.

Comment 4

12 years ago
Have you looked in the junk mail folder? If you have the junk mail filter configured to automatically move or delete junk mail, messages we think are junk will be deleted from the folder.
(Reporter)

Comment 5

12 years ago
nope, they are not filtered as junk. They just go kaboom. Not in the trash folder, not in the junk folder, nothing.

Comment 6

12 years ago
Do you have any extensions installed?

can you e-mail me your msgFilterRules.dat and your prefs.js? Somehow that message was deleted...

You don't have retention settings set on the inbox or the pop3 server account, do you?
(Reporter)

Comment 7

12 years ago
I feel pretty stupid. Turns out that sharing the profile between windows and linux must have tampered with my junk mail rules. It not only began to tag regular mail as junk, but started moving junk mail to the junk folder on the Local Folders, where I never check - because nothing should be there. So this one is probably a dupe of another bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 8

12 years ago
whew, glad you figured it out!
You need to log in before you can comment on or make changes to this bug.