Having a few dozen downloads completed slows down firefox if using download manager

RESOLVED DUPLICATE of bug 161783

Status

()

Toolkit
Downloads API
--
minor
RESOLVED DUPLICATE of bug 161783
11 years ago
10 years ago

People

(Reporter: René, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

If you have downloaded a few dozend files (I would say you can start feeling it from 60 on) every new download takes a lot of time for initialization if you are using download manager. If you disable the download manager it's as quick as expected. If you have more than 200 files in your download history (or on the folder you're downloading to, I think both matter) it takes 5-7 seconds until the download starts, freezing both the download manager thread and firefox itself during this time. After clearing the download history and choosing an empty folder to download to it is fast again even with download manager.

Reproducible: Always

Steps to Reproduce:
1. Choose an empty folder for downloads "save to"
2. Enable option "show download manager"
3. Download about 100 files
4. Disable the option "show download manager" and download one additional file

Actual Results:  
Without download manager there is much less time between clicking on download and firefox being responsive again

Expected Results:  
With download manager turned on the duration for initializing a download should be as short as without download manager.

I've tried this with on multiple computers and with different versions of firefox (1.5, 2.0, Portable 1.5) and it's always the same. It's also independent from the website you're downloading from (except that some are quicker or slower overall, but the difference between using or not using download manager is always there).
(Reporter)

Comment 1

11 years ago
It's a little bit similar to bug 240525

*** This bug has been marked as a duplicate of 161783 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.