Closed Bug 363437 Opened 14 years ago Closed 14 years ago

Amtrak.com broken by reflow landing

Categories

(Core :: Layout: Tables, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 363329

People

(Reporter: kurtbw, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [needs testcase])

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a1) Gecko/20061209 Camino/1.2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a1) Gecko/20061209 Camino/1.2+

Amtrak.com has been broken by the reflow code landing on Camino trunk builds.  The "Go" button to send the form requesting fares and departure times has moved outside of the box where it is supposed to be.  The site worked previously when tested with Camino nightly trunk build 2006112905 (v1.2+) aside from bug #361527.  A screenshot showing current behavior is attached.  Previous behavior with trunk build 2006112905 may be seen as an attachment to bug #362368 (marked as duplicate of bug #361527).

Reproducible: Always

Steps to Reproduce:
1.Surf to amtrak.com, attempt to obtain departure and fare information.
2.
3.

Actual Results:  
"Go" button is outside the box.

Expected Results:  
"Go" button should be inside the box.
Keywords: regression
Didn't we decide that Amtrak.com was using pretty broken HTML/JS in the first place? (See also the various TE bugs filed against that site.)

Please check the site in other Gecko trunk products (Minefield, for example) and see if the behaviour is any different.

cl
Chris, Amtrak.com is indeed broken in a similar manner with Minefield trunk (Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a1)Gecko/20061211 Minefield/3.0a1).

I checked Amtrak.com as I had made a TE contact on a back channel.  This TE contact typed to me that he would effort some work on Amtrak's end.  Thus, this update.
Kicking to Core:General for further triage to appropriate layout component.....
Component: HTML Form Controls → General
Product: Camino → Core
QA Contact: form.controls → general
Whiteboard: [needs testcase]
Version: unspecified → Trunk
same broken layout on

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a1) Gecko/20061210 Minefield/3.0a1 ID:2006121017 [cairo]
Attached file more minimal testcase
The whole thing should stay in the box with a grey background.

The problem comes from some colspan that becomes to wide.
(in the first row).
Think it is a dupe of bug 363329
I remove the colspan attribute on the 3rd cell, 1st row, and adjusted the colspan count on the 2nd row.
The table fits in the grey block (nearly, but that is a font-size issue).
Depends on: 363329
Component: General → Layout: Tables
QA Contact: general → layout.tables
The problem here is related to the middle table (depth-wise) -- it's got 5 columns, with a cell in columns 1, 2-3 (spanning), 4, and 5, and then another row with a nested table spanning all 5 columns.

The problem is that we do the distribution of the spanning cells in a single pass such that row order doesn't matter (something that I want to stick to).  This means that the 5-column-spanning cell needs to allocate extra space (since it doesn't yet consider the space allocated for the 2-column-spanning cell).  This space is spread among all the columns -- although it doesn't show up in the column with the 2-column-spanning cell ("Station List").

*** This bug has been marked as a duplicate of 363329 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.