Closed Bug 363496 Opened 14 years ago Closed 13 years ago

gmail talk, onclick textarea creates new space in contacts list

Categories

(Core :: Layout: Tables, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: janklopper, Assigned: dbaron)

References

()

Details

(Keywords: qawanted, regression)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a1) Gecko/20061211 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a1) Gecko/20061211 Minefield/3.0a1

In gmail talk (online), clicking in the textarea where you are supposed to type in text to chat, produces an increase in the height of the blue border below the contacts list on the left.

Clicking multiple times increases this space,
Receiving a message either increases the space, or resets it.

This might be a bug in Gmail, but i haven't seen this behavior before.
Since the gmail/google people are probably watching this (and mozilla folks could poke their google payed peers), i thought i'd list this as a bug for firefox 3.0 / minefield. 

Reproducible: Always

Steps to Reproduce:
1.open gmail
2.chat to someone,
3.notice the blue border below contacts growing and shrinking



Expected Results:  
firefox 2 behavior would be nice,

This build runs on linux, with no extentions.
Duplicate of this bug: 364314
Depends on: 368621
Status: UNCONFIRMED → NEW
Component: General → Layout: Tables
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
Version: unspecified → Trunk
QA Contact: general → layout.tables
Keywords: regression
Duplicate of this bug: 375797
Duplicate of this bug: 366233
Keywords: qawanted
Flags: in-testsuite?
It also happens if you hover over names in the Quick Contacts.

Using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070413 Minefield/3.0a4pre - Build ID: 2007041304
Assignee: nobody → dbaron
Duplicate of this bug: 382344
Duplicate of this bug: 382371
Duplicate of this bug: 382315
VERIFIED

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070618 Minefield/3.0a6pre ID:2007061816

[^^oooops sorry wrong comment]

this was fixed by bug 381507.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
So I don't see the expansion problem anymore -- and haven't for a while -- but I still see the two "Buttons" at the bottom missing -- because they're being pushed down by a table that has height="100%" but for which we should be ignoring the height="100%".  I think this is basically now about the issue of when to do special height reflows; we're now doing them a bit too much.

I have a bunch of testcases at http://dbaron.org/css/test/2006/percent-height-in-tables written for bug 359481 and bug 381507.
I guess I'll reopen bug 366233 to cover the missing buttons problem.
I don't think anyone is going to take the time to make a reduced testcase from Gmail for an already-fixed bug.  Bug 381507 itself already has automated tests.
Flags: in-testsuite? → in-testsuite-
You need to log in before you can comment on or make changes to this bug.