Closed Bug 363499 Opened 13 years ago Closed 13 years ago

Move pageload_server from axolotl to dm-pageload01 (pageload.build.mozilla.org)

Categories

(Webtools Graveyard :: Tinderbox, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tfullhart, Assigned: reed)

References

Details

Attachments

(6 files, 1 obsolete file)

axolotl is old and IT wants to get rid of it. bm-tester01.build.mozilla.org is the new page-load server. It seems to work ok from my laptop, but it needs to be tested to make sure it works before we start moving tinderboxes over to using it.

To change which server a tinderbox uses, it's the $pageload_server variable in tinder-config.pl.
Status: NEW → ASSIGNED
Should be applied to the REFLOW_BRANCH branch in /cvsroot/mozilla/tools/tinderbox-configs.
Attachment #248304 - Flags: review?(preed)
Component: Build Config → Tinderbox Configuration
Flags: review?(preed)
Product: Firefox → mozilla.org
QA Contact: build.config → ccooper
Version: unspecified → other
Attachment #248304 - Flags: review?(preed)
Attachment #248304 - Flags: review?(preed) → review+
Landed:

Checking in tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.2.28.2; previous revision: 1.2.28.1
done
Should be applied to the REFLOW_BRANCH branch in
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32.
Attachment #249461 - Flags: review?(rhelmer)
Attachment #249461 - Flags: review?(rhelmer) → review?(ccooper)
Attachment #249461 - Flags: review?(ccooper) → review+
Checking in tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.2.28.3; previous revision: 1.2.28.2
done
Here's a patch showing all diffs between page-loader as it is in CVS and as it is in production. The "CGI" directory should probably be checked in, as it contains an old version of CGI/Request.pm that is hard to find nowadays.

I don't want to check this patch in as-is; putting it here so we don't lose it.
The regxpcom test is failing for the Fx-Reflow tinderbox, which is preventing me from fully testing the LayoutPerformanceTest.

If approved, please land this patch for me. Thank you.
Attachment #250510 - Flags: review?(preed)
(In reply to comment #6)
> Created an attachment (id=250510) [details]
> Patch to tinder-config.pl to turn off regxpcom test
> 
> The regxpcom test is failing for the Fx-Reflow tinderbox, which is preventing
> me from fully testing the LayoutPerformanceTest.
> 
> If approved, please land this patch for me. Thank you.

Landed.

Checking in tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.2.28.4; previous revision: 1.2.28.3
done
Attachment #250510 - Flags: review?(preed) → review+
Taking TR's bug; I'll retriage these shortly.
Assignee: tfullhart → preed
Status: ASSIGNED → NEW
Reassigning bugs I'm not actively working on back into the triage pool.
Assignee: preed → build
Axolotl is going byebye with or without this moved at the end of next week.  If we can get this off the box by the end of this week it'd be way cool.  I'm willing to help if you need it.
Severity: normal → critical
Is bm-tester01 the permanent place for this? 

We should merge and land attachment 249486 [details] [diff] [review] and set up the pageload server to check out from CVS automatically.
Duplicate of this bug: 374729
I can't resolve bm-tester01.build.mozilla.org from the community build network or from the outside - what server are we supposed to transition to?
Assignee: build → reed
The correct server to use is "pageload.build.mozilla.org".

Build: Please remember to send out a notice for this asap, as I would like to do this next week.
Status: NEW → ASSIGNED
Whiteboard: Possibly scheduled for week of 5/27
Whiteboard: Possibly scheduled for week of 5/27 → Scheduled for Thursday, June 7th, at 7pm PDT (2am UTC Friday)
I can't resolve that name either.
The current server is only available inside the build LAN.  When we set it up, we were told that's all it would need to be accessible from.
Note that this has been in the works for like a year or something, a lot could have changed in that time.  Do we have tinderboxes using it from outside now?
OK, this server was moved to the DMZ yesterday (nobody said so on the bug).  Failure to resolve was a DNS issue, serial number never got bumped when the external version of it was put in.  It should resolve now.
Yup, it does.  I've redirected the Camino tinder-configs to use this server.
Summary: Move pageload_server from axolotl to bm-tester01 → Move pageload_server from axolotl to dm-pageload01 (pageload.build.mozilla.org)
The pagelaoad test at pageload.build.mozilla.org is giving me img links that refer to bm-tester01.mozilla.org.  I can't resolve this name.  It's causing Tp to be all screwy.
(In reply to comment #20)
> The pagelaoad test at pageload.build.mozilla.org is giving me img links that
> refer to bm-tester01.mozilla.org.  I can't resolve this name.  It's causing Tp
> to be all screwy.

Fixed. Sorry about that.
Comment on attachment 267647 [details] [diff] [review]
Update tinderbox configs to use new locations for external apps (results_server / pageload_server) - v1


>===================================================================
>RCS file: /cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v
>retrieving revision 1.2.2.6
>diff -u -p -r1.2.2.6 tinder-config.pl
>--- firefox/win32/tinder-config.pl	18 May 2007 21:04:20 -0000	1.2.2.6
>+++ firefox/win32/tinder-config.pl	7 Jun 2007 23:13:40 -0000
>@@ -87,7 +87,7 @@ $GraphNameOverride        = 'fx-win32-tb
> # - cmp@mozilla.org
> #$results_server           = "build-graphs.mozilla.org";
> 
>-$pageload_server          = "axolotl.mozilla.org";  # localhost
>+$pageload_server          = "pageload.build.mozilla.org";  # localhost
> # FIXME rhelmer testing new pageserver for reed 20070517 
> #$pageload_server          = "bm-tester01.build.mozilla.org"; 

Want to clean this comment up while you're here?

>-#$results_server           = "axolotl.mozilla.org"; # was tegu
>+#$results_server           = "build-graphs.mozilla.org"; # was tegu
> #$pageload_server          = "spider";  # localhost

Let's no fix commented-out page servers; if we ever need to uncomment them, someone should think clearly about what they should be pointing at anyway. (It also adds a lot of useless gunk to this patch.)

I already asked you this on IRC, but in the bug, could you include which branches the patch affects?
Attachment #267647 - Flags: review?(preed) → review-
This changes these branches:
CAMINO_1_5_BRANCH feature_gcc411 feature_places feature_textframe FIREFOX_CAIRO_WORK GTK1 HEAD l10n MOZILLA_1_8_0_BRANCH MOZILLA_1_8_0_BRANCH_l10n MOZILLA_1_8_BRANCH MOZILLA_1_8_BRANCH_l10n MOZILLA_1_8_BRANCH_test_mem MOZILLA_1_8_BRANCH_test_perf REFLOW_BRANCH test_mem test_perf test_unit XR_APPS
Attachment #267647 - Attachment is obsolete: true
Attachment #267662 - Flags: review?(preed)
Comment on attachment 267662 [details] [diff] [review]
Update production tinderbox configs to use new location of pageload server - v2

Looks good; thanks for doing this reed.

Let's land this together on IRC during the outage window.
Attachment #267662 - Flags: review?(preed) → review+
Comment on attachment 267662 [details] [diff] [review]
Update production tinderbox configs to use new location of pageload server - v2

For the record, this patch modifies the following branches for tinderbox-configs:
feature_gcc411 feature_places feature_textframe FIREFOX_CAIRO_WORK HEAD MOZILLA_1_8_0_BRANCH MOZILLA_1_8_BRANCH test_unit XR_APPS
Checking in firefox/linux/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/linux/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.4.2.5; previous revision: 1.4.2.4
done
Checking in firefox/win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.2.2.7; previous revision: 1.2.2.6
done
Checking in firefox/macosx/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/macosx/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.16.2.4; previous revision: 1.16.2.3
done
Checking in firefox/win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.10.2.4; previous revision: 1.10.2.3
done
Checking in firefox/macosx/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/macosx/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.3.2.10; previous revision: 1.3.2.9
done
Checking in firefox/macosx/tinder-config.pl-cocoa;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/macosx/Attic/tinder-config.pl-cocoa,v  <--  tinder-config.pl-cocoa
new revision: 1.1.2.9; previous revision: 1.1.2.8
done
Checking in firefox/linux/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/linux/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.5; previous revision: 1.4
done
Checking in firefox/macosx/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/macosx/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.18; previous revision: 1.17
done
Checking in firefox/win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.11; previous revision: 1.10
done
Checking in seamonkey/linux/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/seamonkey/linux/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.7; previous revision: 1.6
done
Checking in seamonkey/win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/seamonkey/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.7; previous revision: 1.6
done
Checking in firefox/win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.2.18.3; previous revision: 1.2.18.2
done
Checking in firefox/linux/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/linux/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.1.12.3; previous revision: 1.1.12.2
done
Checking in firefox/win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.2.10.2; previous revision: 1.2.10.1
done
Checking in firefox/win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.2.26.2; previous revision: 1.2.26.1
done
Checking in tinder-defaults.pl;
/cvsroot/mozilla/tools/tinderbox/tinder-defaults.pl,v  <--  tinder-defaults.pl
new revision: 1.110; previous revision: 1.109
done
Checking in firefox/macosx/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/macosx/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.7.2.1; previous revision: 1.7
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Comment on attachment 267676 [details] [diff] [review]
Update pageload server for test_perf boxen

Looks like they were already using spider, but the FQDN can't hurt. Thanks reed.
Attachment #267676 - Flags: review?(preed) → review+
Checking in firefox/linux/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/linux/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.1.6.12; previous revision: 1.1.6.11
done
Checking in firefox/win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.2.6.11; previous revision: 1.2.6.10
done
Checking in firefox/linux/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/linux/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.1.10.9; previous revision: 1.1.10.8
done
Checking in firefox/win32/tinder-config.pl;
/cvsroot/mozilla/tools/tinderbox-configs/firefox/win32/tinder-config.pl,v  <--  tinder-config.pl
new revision: 1.2.8.8; previous revision: 1.2.8.7
done
Whiteboard: Scheduled for Thursday, June 7th, at 7pm PDT (2am UTC Friday)
Depends on: 384310
Depends on: 387463
Component: Tinderbox Configuration → Tinderbox
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.